summaryrefslogtreecommitdiff
path: root/x11-misc/rofi/rofi-1.3.0.ebuild
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-12-27 11:16:37 +0100
committerJeroen Roovers <jer@gentoo.org>2016-12-27 11:17:02 +0100
commit4a75bf0d12c8636828f3df7c9fa6bcc5abbe62b9 (patch)
tree3977538fbd9b02ad612195980111758d08956b59 /x11-misc/rofi/rofi-1.3.0.ebuild
parent84a2cab73671509af8538ba8913d2d02b3cf2b65 (diff)
downloadgentoo-4a75bf0d12c8636828f3df7c9fa6bcc5abbe62b9.tar.gz
gentoo-4a75bf0d12c8636828f3df7c9fa6bcc5abbe62b9.tar.xz
x11-misc/rofi: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-misc/rofi/rofi-1.3.0.ebuild')
-rw-r--r--x11-misc/rofi/rofi-1.3.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/rofi/rofi-1.3.0.ebuild b/x11-misc/rofi/rofi-1.3.0.ebuild
new file mode 100644
index 00000000000..7095c50ef20
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://davedavenport.github.io/rofi/"
+SRC_URI="https://github.com/DaveDavenport/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable windowmode)
+}
+
+src_test() {
+ emake test
+}