summaryrefslogtreecommitdiff
path: root/x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-01-28 11:10:03 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-01-28 11:15:48 +0300
commit0f35eaef18ee050158ef38cc6d8123a500e3191d (patch)
treed7f1b8fe27a533d71a521b9b9597383cabe65f96 /x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
parent3f15ba5e4a8f63a9d0dd0b773f4149342befa988 (diff)
downloadgentoo-0f35eaef18ee050158ef38cc6d8123a500e3191d.tar.gz
gentoo-0f35eaef18ee050158ef38cc6d8123a500e3191d.tar.xz
Move x11-apps/ccsm and x11-apps/simple-ccsm to x11-misc/ccsm and
x11-misc/simple-ccsm respectively Gentoo-Bug: 571838 Gentoo-Bug: 571852
Diffstat (limited to 'x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild')
-rw-r--r--x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild b/x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
new file mode 100644
index 00000000000..ef064ce7560
--- /dev/null
+++ b/x11-misc/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="Simplified Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+RDEPEND="
+ >=dev-python/compizconfig-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
+ >=x11-apps/ccsm-${PV}[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # return error if wrong arguments passed to setup.py
+ sed -i -e 's/raise SystemExit/\0(1)/' setup.py || die 'sed on setup.py failed'
+ # fix desktop file
+ sed -i \
+ -e '/Categories/s/Compiz/X-\0/' \
+ -e '/Encoding/d' \
+ "${PN}".desktop.in || die "sed on ${PN}.desktop.in failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=( build --prefix=/usr )
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}