summaryrefslogtreecommitdiff
path: root/x11-misc/wmname
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/wmname
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/wmname')
-rw-r--r--x11-misc/wmname/Manifest1
-rw-r--r--x11-misc/wmname/files/wmname-0.1-buildsystem.patch26
-rw-r--r--x11-misc/wmname/metadata.xml9
-rw-r--r--x11-misc/wmname/wmname-0.1.ebuild33
4 files changed, 69 insertions, 0 deletions
diff --git a/x11-misc/wmname/Manifest b/x11-misc/wmname/Manifest
new file mode 100644
index 00000000000..d7add68a903
--- /dev/null
+++ b/x11-misc/wmname/Manifest
@@ -0,0 +1 @@
+DIST wmname-0.1.tar.gz 2512 SHA256 559ad188b2913167dcbb37ecfbb7ed474a7ec4bbcb0129d8d5d08cb9208d02c5 SHA512 e57100f8de2579f4090c0aaf5a5b134d03bcbcdca5c6d005b12ce39ad322d96651bb13d151cf259e935e6c50e7b21bde43a4eace112be80983a92f92b99f192f WHIRLPOOL d46dafea93cd673d6e6285e266745690a5ab9d4fac11f171d3c143fa04563bccfb6a4927cb052fd3d15f27a11b0e76245e1e86458b36a03fcde154283b46dd0d
diff --git a/x11-misc/wmname/files/wmname-0.1-buildsystem.patch b/x11-misc/wmname/files/wmname-0.1-buildsystem.patch
new file mode 100644
index 00000000000..bee2131d9be
--- /dev/null
+++ b/x11-misc/wmname/files/wmname-0.1-buildsystem.patch
@@ -0,0 +1,26 @@
+--- wmname-0.1/config.mk
++++ wmname-0.1/config.mk
+@@ -16,9 +16,9 @@
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\"
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+-LDFLAGS = -s ${LIBS}
++CFLAGS += -std=c99 -pedantic ${INCS} ${CPPFLAGS}
++LDFLAGS += ${LIBS}
+
+ # compiler and linker
+-CC = cc
+-LD = ${CC}
++CC ?= cc
++LD ?= ${CC}
+--- wmname-0.1/Makefile
++++ wmname-0.1/Makefile
+@@ -23,7 +23,6 @@
+ wmname: ${OBJ}
+ @echo LD $@
+ @${LD} -o $@ ${OBJ} ${LDFLAGS}
+- @strip $@
+
+ clean:
+ @echo cleaning
diff --git a/x11-misc/wmname/metadata.xml b/x11-misc/wmname/metadata.xml
new file mode 100644
index 00000000000..59acc2cc580
--- /dev/null
+++ b/x11-misc/wmname/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-misc/wmname/wmname-0.1.ebuild b/x11-misc/wmname/wmname-0.1.ebuild
new file mode 100644
index 00000000000..e1d4f6967c2
--- /dev/null
+++ b/x11-misc/wmname/wmname-0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="utility to set the name of your window manager"
+HOMEPAGE="http://tools.suckless.org/wmname"
+SRC_URI="http://dl.suckless.org/tools/wmname-0.1.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install || die
+ dodoc README || die
+}