summaryrefslogtreecommitdiff
path: root/x11-misc/xcape
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xcape
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xcape')
-rw-r--r--x11-misc/xcape/Manifest2
-rw-r--r--x11-misc/xcape/metadata.xml18
-rw-r--r--x11-misc/xcape/xcape-1.0.ebuild28
-rw-r--r--x11-misc/xcape/xcape-1.1.ebuild38
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-misc/xcape/Manifest b/x11-misc/xcape/Manifest
new file mode 100644
index 00000000000..2393763efe8
--- /dev/null
+++ b/x11-misc/xcape/Manifest
@@ -0,0 +1,2 @@
+DIST xcape-1.0.tar.gz 16409 SHA256 1ba287cf98a417fd67afff58b8f5f4c00e62b3e5195d3aea48b11bba70649561 SHA512 289954bf6ba7dc5f260354c677db11954abcaa4dadeee64566a4524c54529754ccb771816ceabee238dad0f77ba3acd8536c0e1d4817d72e71e76b2f7975fed4 WHIRLPOOL ca54bfb111f31969c7243377c32748580b9ebce22035e034453d80efc6fc86d9c2ead7d8ec17b44b81266d0ac94c8c2139a70c5db116a1f6385c3c991682099b
+DIST xcape-1.1.tar.gz 18458 SHA256 69ae927a6b2b1268a809b9c3af7c4f94584458f022beb6e2ca3e6bc3ba8a6d4a SHA512 6234e50a38003249eae563ff22ce923c3032e44b358e8e49550001c60246be1159a47f60f52d42040dda88d5396228b8daf4f0f4b03db2bcfc514c634c81540f WHIRLPOOL 1fa89d34143fb98adabdb2b41528352a3f4cd6778324f07ffbd17a921c7fded07a91555eb877361af8452cfd3d516a5eecf6c8ac3ebf565ae89d032ee2c9b06d
diff --git a/x11-misc/xcape/metadata.xml b/x11-misc/xcape/metadata.xml
new file mode 100644
index 00000000000..43e57ddbd5a
--- /dev/null
+++ b/x11-misc/xcape/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>aditsu@yahoo.com</email>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">alols/xcape</remote-id>
+ <bugs-to>https://github.com/alols/xcape/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xcape/xcape-1.0.ebuild b/x11-misc/xcape/xcape-1.0.ebuild
new file mode 100644
index 00000000000..3f730fc33dd
--- /dev/null
+++ b/x11-misc/xcape/xcape-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
+HOMEPAGE="https://github.com/alols/xcape"
+SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
diff --git a/x11-misc/xcape/xcape-1.1.ebuild b/x11-misc/xcape/xcape-1.1.ebuild
new file mode 100644
index 00000000000..7356149a4f2
--- /dev/null
+++ b/x11-misc/xcape/xcape-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
+HOMEPAGE="https://github.com/alols/xcape"
+SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix path to man and to pkg-config
+ sed -i \
+ -e "/MANDIR/s:local:share:" \
+ -e "s/pkg-config/$(tc-getPKG_CONFIG)/" \
+ Makefile || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}