summaryrefslogtreecommitdiff
path: root/x11-misc/xearth
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xearth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xearth')
-rw-r--r--x11-misc/xearth/Manifest1
-rw-r--r--x11-misc/xearth/files/xearth-1.1-include.patch10
-rw-r--r--x11-misc/xearth/metadata.xml6
-rw-r--r--x11-misc/xearth/xearth-1.1-r1.ebuild48
4 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/xearth/Manifest b/x11-misc/xearth/Manifest
new file mode 100644
index 00000000000..f7b02372b91
--- /dev/null
+++ b/x11-misc/xearth/Manifest
@@ -0,0 +1 @@
+DIST xearth-1.1.tar.gz 157887 SHA256 bcb1407cc35b3f6dd3606b2c6072273b6a912cbd9ed1ae22fb2d26694541309c SHA512 ab1c146385a0e61f6208a0218cabc8a10902f52feb50f328a330cdbddc5d2eff2c3efdf6719b625bcc07171ed2fd6201230ad8a71cd77a451ad9c81383bfd46e WHIRLPOOL c5884f3d7bed815f3e9ebe96c078d8646602117744377d8b83065aa4218869a9acdfcd6373d65d6702a1f051a301a0f881cb7f2aae00b0e1db057b13759ab727
diff --git a/x11-misc/xearth/files/xearth-1.1-include.patch b/x11-misc/xearth/files/xearth-1.1-include.patch
new file mode 100644
index 00000000000..d3974b43f2e
--- /dev/null
+++ b/x11-misc/xearth/files/xearth-1.1-include.patch
@@ -0,0 +1,10 @@
+--- a/gifout.c 1999-11-07 07:51:34.000000000 +0100
++++ b/gifout.c 2010-09-18 02:44:44.000000000 +0200
+@@ -44,6 +44,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "port.h"
+ #include "gifint.h"
+ #include "kljcpyrt.h"
diff --git a/x11-misc/xearth/metadata.xml b/x11-misc/xearth/metadata.xml
new file mode 100644
index 00000000000..0e92f1446c7
--- /dev/null
+++ b/x11-misc/xearth/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
+
diff --git a/x11-misc/xearth/xearth-1.1-r1.ebuild b/x11-misc/xearth/xearth-1.1-r1.ebuild
new file mode 100644
index 00000000000..e00b1c5b4ee
--- /dev/null
+++ b/x11-misc/xearth/xearth-1.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+HOMEPAGE="http://hewgill.com/xearth/original/"
+DESCRIPTION="Xearth sets the X root window to an image of the Earth"
+SRC_URI="ftp://cag.lcs.mit.edu/pub/tuna/${P}.tar.gz
+ ftp://ftp.cs.colorado.edu/users/tuna/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="xearth"
+KEYWORDS="alpha amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ app-text/rman
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ newman xearth.man xearth.1
+ dobin xearth
+ dodoc BUILT-IN GAMMA-TEST HISTORY README
+}