summaryrefslogtreecommitdiff
path: root/x11-misc/xkeyboard-config
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xkeyboard-config
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/Manifest2
-rw-r--r--x11-misc/xkeyboard-config/metadata.xml5
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild48
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.15.ebuild48
4 files changed, 103 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
new file mode 100644
index 00000000000..8f92990a9bd
--- /dev/null
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -0,0 +1,2 @@
+DIST xkeyboard-config-2.14.tar.bz2 953589 SHA256 dc91458a214c56a35727f9e523fc647615de64137057ca6ee4d4d4474a4bb2ae SHA512 b8c9affafcc61fde32bb90fa83c2e5a05a0903a9ec71ee8878a460b6173c82c5d5c95d3735d1e0f65bcdbcd66842788275523ab5f6e78c2e56266cee0d74da58 WHIRLPOOL c3ca9816b0eac131c7556da0f42987b4fd77d4565a92103b2bda0d5b9264893f9e61d2756e231bb9bac353397a310fe5a0415536496b8758e89545676f33741e
+DIST xkeyboard-config-2.15.tar.bz2 958523 SHA256 0e443cf7ca2f0b40846472c029647a05933fc705d611e1478c4db8a48a6f38bf SHA512 64212cdf75bdf7af29134d718a041489c9bca20b1c7d6d8e4b81373eb72b26deed0728a23448083fc918c8cb8bb41341d76de26c85496a528aa120a47d268d66 WHIRLPOOL f9eaf8e2cc6be78a582b1ce26dd6da4255aa14faef95267b8cea12d253550ba0304c664209a5675bad9875ad7304f9d4dc13f6a0db498a79e3ebf6502c70ebae
diff --git a/x11-misc/xkeyboard-config/metadata.xml b/x11-misc/xkeyboard-config/metadata.xml
new file mode 100644
index 00000000000..01c4c004e73
--- /dev/null
+++ b/x11-misc/xkeyboard-config/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild
new file mode 100644
index 00000000000..ca060ab4f91
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=x11-apps/xkbcomp-1.2.3
+ >=x11-libs/libX11-1.4.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=x11-proto/xproto-7.0.20"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}
+
+src_compile() {
+ # cleanup to make sure .dir files are regenerated
+ # bug #328455 c#26
+ xorg-2_src_compile clean
+ xorg-2_src_compile
+}
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.15.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.15.ebuild
new file mode 100644
index 00000000000..20b9c27eb7d
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=x11-apps/xkbcomp-1.2.3
+ >=x11-libs/libX11-1.4.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=x11-proto/xproto-7.0.20"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}
+
+src_compile() {
+ # cleanup to make sure .dir files are regenerated
+ # bug #328455 c#26
+ xorg-2_src_compile clean
+ xorg-2_src_compile
+}