summaryrefslogtreecommitdiff
path: root/x11-misc/xnots
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xnots
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xnots')
-rw-r--r--x11-misc/xnots/Manifest1
-rw-r--r--x11-misc/xnots/metadata.xml8
-rw-r--r--x11-misc/xnots/xnots-0.2.1-r1.ebuild48
3 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/xnots/Manifest b/x11-misc/xnots/Manifest
new file mode 100644
index 00000000000..1183e16a836
--- /dev/null
+++ b/x11-misc/xnots/Manifest
@@ -0,0 +1 @@
+DIST xnots-0.2.1.tar.gz 41442 SHA256 80bbab0334880f79aa12cf17ebffc5730a85dc537e8e6208169720656ecd72ca SHA512 bb1a334150aac932839c8d9e04d8c9f1c419f5221a218fbbe3523060fbb8d62e616f89ec06a8237fa290de37db103e98a560953ef820ef016f35dd5c844eb65c WHIRLPOOL 1ed783f7167fd8836bf939ec09eabc7e25a229e6f95c3d3f5e52975dc97e2b94064d48f5a8b03ec6d55121292ff661283943e0c2b562965b7bf74068232a70b7
diff --git a/x11-misc/xnots/metadata.xml b/x11-misc/xnots/metadata.xml
new file mode 100644
index 00000000000..d62a9e754cd
--- /dev/null
+++ b/x11-misc/xnots/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">xnots</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xnots/xnots-0.2.1-r1.ebuild b/x11-misc/xnots/xnots-0.2.1-r1.ebuild
new file mode 100644
index 00000000000..89f8649b8da
--- /dev/null
+++ b/x11-misc/xnots/xnots-0.2.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="A desktop sticky note program for the unix geek"
+HOMEPAGE="http://xnots.sourceforge.net"
+SRC_URI="mirror://sourceforge/xnots/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="vim-syntax"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ x11-libs/pango[X]"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/renderproto
+ x11-proto/randrproto"
+
+src_prepare() {
+ sed -i -e 's|LICENCE||g' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" NO_DEBUG=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ mandir=/usr/share/man \
+ prefix=/usr \
+ install
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins etc/xnots.vim
+ fi
+}