summaryrefslogtreecommitdiff
path: root/x11-misc/xoo
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xoo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xoo')
-rw-r--r--x11-misc/xoo/Manifest1
-rw-r--r--x11-misc/xoo/metadata.xml5
-rw-r--r--x11-misc/xoo/xoo-0.7.ebuild35
3 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/xoo/Manifest b/x11-misc/xoo/Manifest
new file mode 100644
index 00000000000..6be36eb2803
--- /dev/null
+++ b/x11-misc/xoo/Manifest
@@ -0,0 +1 @@
+DIST xoo-0.7.tar.gz 301563 RMD160 86865d8ade4441f7ad75b719fa6eb0c4a65d857f SHA1 dfdaa8bb1d2a4ff07c52b676648ce2c2c1adf7a1 SHA256 69796891a93887496d99c867bb70208830ceb6c3671fca0ecc70a564a14ae20a
diff --git a/x11-misc/xoo/metadata.xml b/x11-misc/xoo/metadata.xml
new file mode 100644
index 00000000000..6a17403e0ad
--- /dev/null
+++ b/x11-misc/xoo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gpe</herd>
+</pkgmetadata>
diff --git a/x11-misc/xoo/xoo-0.7.ebuild b/x11-misc/xoo/xoo-0.7.ebuild
new file mode 100644
index 00000000000..1b0ef725816
--- /dev/null
+++ b/x11-misc/xoo/xoo-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2006-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A graphical wrapper around xnest"
+HOMEPAGE="http://projects.o-hand.com/xoo"
+SRC_URI="http://projects.o-hand.com/sources/xoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gnome"
+
+DEPEND="gnome? ( gnome-base/gconf )
+ gnome-base/libglade
+ x11-libs/libXtst
+ x11-base/xorg-server"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix default Xnest binary path.
+ sed -e "s:/usr/X11R6/bin/Xnest:$(type -P Xnest):" -i src/main.c || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable gnome gconf)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog NEWS README TODO
+}