summaryrefslogtreecommitdiff
path: root/x11-misc/xrootconsole
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xrootconsole
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xrootconsole')
-rw-r--r--x11-misc/xrootconsole/Manifest1
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.4.parse-color.patch23
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch36
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.6.manpage.patch22
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.6.noversion.patch52
-rw-r--r--x11-misc/xrootconsole/metadata.xml8
-rw-r--r--x11-misc/xrootconsole/xrootconsole-0.6.ebuild43
7 files changed, 185 insertions, 0 deletions
diff --git a/x11-misc/xrootconsole/Manifest b/x11-misc/xrootconsole/Manifest
new file mode 100644
index 00000000000..4f3b14d7272
--- /dev/null
+++ b/x11-misc/xrootconsole/Manifest
@@ -0,0 +1 @@
+DIST xrootconsole-0.6.tar.gz 15951 SHA256 8306de6f4d3f39677334ee65214e46729cf2dd89aeff1705df3c499738a4076d
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.4.parse-color.patch b/x11-misc/xrootconsole/files/xrootconsole-0.4.parse-color.patch
new file mode 100644
index 00000000000..78114de4df5
--- /dev/null
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.4.parse-color.patch
@@ -0,0 +1,23 @@
+diff -u xrootconsole-0.4/util.c xrootconsole-0.4.new/util.c
+--- xrootconsole-0.4/util.c 2000-10-10 04:17:53.000000000 +0200
++++ xrootconsole-0.4.new/util.c 2004-02-17 23:59:45.000000000 +0100
+@@ -53,16 +53,16 @@
+
+
+ unsigned long load_color(const char* s, Display *dpy) {
+- XColor ce, cs;
++ XColor ce;
+ Colormap colormap = DefaultColormap(dpy, DefaultScreen(dpy));
+
+- if (XLookupColor(dpy, colormap, s, &ce, &cs)) {
++ if (XParseColor(dpy, colormap, s, &ce)) {
+ if (XAllocColor(dpy, colormap, &ce)) return ce.pixel;
+
+ fprintf(stderr, "Warning: could not allocate color\n");
+ return WhitePixel(dpy, DefaultScreen(dpy));
+ }
+
+- fprintf(stderr, "Warning: could not lookup color\n");
++ fprintf(stderr, "Warning: could not parse color\n");
+ return WhitePixel(dpy, DefaultScreen(dpy));
+ }
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch b/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
new file mode 100644
index 00000000000..37fd4fb074a
--- /dev/null
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
@@ -0,0 +1,36 @@
+--- xrootconsole-0.6/Makefile.org 2004-02-20 22:53:28.000000000 +0100
++++ xrootconsole-0.6/Makefile 2010-02-08 12:01:11.000000000 +0100
+@@ -43,20 +43,16 @@
+ else echo Bleeding Edge Version; \
+ fi;)
+
+-CC = gcc
+-CPPFLAGS =
+-
+ # for production
+-CFLAGS = -O2 -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
+- -I /usr/X11R6/include
+-LDFLAGS = -s
++CFLAGS += -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
++ $(shell pkg-config --cflags x11)
+
+ # for testing
+ #CFLAGS = -g -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION) (debug build)\"" \
+ -I /usr/X11R6/include
+ #LDFLAGS =
+
+-LIBS = -L/usr/X11R6/lib -lX11 -lutil
++LIBS = $(shell pkg-config --libs x11) -lutil
+
+ OBJS = main.o util.o
+
+@@ -76,5 +72,7 @@
+ rm -f $(EXEC) *.o core *~
+
+ install: $(EXEC)
+- cp $(EXEC) $(BINDIR)
+- cp $(MANFILE) $(MANDIR)
++ install -d $(BINDIR)
++ install -d $(MANDIR)
++ install $(EXEC) $(BINDIR)
++ install $(MANFILE) $(MANDIR)
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.6.manpage.patch b/x11-misc/xrootconsole/files/xrootconsole-0.6.manpage.patch
new file mode 100644
index 00000000000..55718f22238
--- /dev/null
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.6.manpage.patch
@@ -0,0 +1,22 @@
+--- xrootconsole.1.orig 2005-03-06 16:59:05.837673328 +0900
++++ xrootconsole.1 2005-03-06 17:04:36.493406016 +0900
+@@ -38,6 +38,9 @@
+ .Ar number
+ columns wide. Text is written vertically down each column in the order in
+ which text is received from the input file. The default is 1.
++.It Fl -solid
++This option makes the background a solid color. The default is to use a
++shaded/transparent background.
+ .It Fl -topdown
+ Forces xrootconsole to display new lines from its input at the top of the
+ screen, scrolling previous lines down. Default behavior is to insert new
+@@ -45,6 +48,9 @@
+ .It Fl -wrap
+ Rather than truncating long lines, this option specifies that xrootconsole
+ should wrap excess text to the following line or lines, as necessary.
++.It Fl -noversion
++Tells xrootconsole not to display its version as the first line of output in
++the root window. Default behavior is to include version information.
+ .It Fl geometry Ar geometry
+ This option specifies the preferred size and position of the window; see
+ .Xr X 1 .
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.6.noversion.patch b/x11-misc/xrootconsole/files/xrootconsole-0.6.noversion.patch
new file mode 100644
index 00000000000..b1ede402311
--- /dev/null
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.6.noversion.patch
@@ -0,0 +1,52 @@
+--- main.c.orig 2004-02-21 07:31:53.000000000 +0900
++++ main.c 2005-03-06 16:34:27.949346504 +0900
+@@ -68,6 +68,7 @@
+ " --solid make background a solid color, not shaded-transparent\n" \
+ " --topdown insert lines at the top and scroll the rest down\n" \
+ " --wrap wrap long lines, instead of cutting them off\n" \
++" --noversion do not display xrootwindow version in output\n" \
+ " -h or --help a familiar-looking help screen\n" \
+ " -v or --version displays the version number\n" \
+ " [console] filename to read (defaults to standard input)\n" \
+@@ -102,6 +103,7 @@
+ int wrap;
+ int topdown;
+ int solid;
++ int show_version;
+ } InitOptions;
+
+ typedef struct {
+@@ -219,6 +221,7 @@
+ io->wrap = DEFAULT_WRAP;
+ io->topdown = DEFAULT_TOPDOWN;
+ io->solid = DEFAULT_SOLID;
++ io->show_version = 1;
+
+ /* Process command-line arguments */
+ while (*++argv != NULL) {
+@@ -236,6 +239,8 @@
+ io->bw = atoi(*++argv);
+ else if (!strcmp(*argv, "-columns") || !strcmp(*argv, "-c"))
+ io->tc = atoi(*++argv);
++ else if (!strcmp(*argv, "--noversion"))
++ io->show_version = 0;
+ else if (!strcmp(*argv, "--solid"))
+ io->solid = True;
+ else if (!strcmp(*argv, "--wrap"))
+@@ -560,10 +565,12 @@
+ init_console(io.console_name, ws.colwidth, ws.nlines, &cs);
+
+ /* Display a message */
+- put("xrootconsole ",&io,&ws,&cs);
+- put(XROOTCONSOLE_VERSION,&io,&ws,&cs);
+- put("\n",&io,&ws,&cs);
+-
++ if (io.show_version) {
++ put("xrootconsole ",&io,&ws,&cs);
++ put(XROOTCONSOLE_VERSION,&io,&ws,&cs);
++ put("\n",&io,&ws,&cs);
++ }
++
+ draw_pixmap(&io,&ws,&cs);
+
+ event_loop(&io,&ws,&cs);
diff --git a/x11-misc/xrootconsole/metadata.xml b/x11-misc/xrootconsole/metadata.xml
new file mode 100644
index 00000000000..b5be7343e36
--- /dev/null
+++ b/x11-misc/xrootconsole/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">xrootconsole</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xrootconsole/xrootconsole-0.6.ebuild b/x11-misc/xrootconsole/xrootconsole-0.6.ebuild
new file mode 100644
index 00000000000..7bf3fc6a8e1
--- /dev/null
+++ b/x11-misc/xrootconsole/xrootconsole-0.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A utility that displays its input in a text box on your root window"
+HOMEPAGE="http://sourceforge.net/projects/xrootconsole/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}.noversion.patch"
+ epatch "${FILESDIR}/${P}.makefile.patch"
+ epatch "${FILESDIR}/${P}.manpage.patch"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin
+
+ make \
+ MANDIR="${D}usr/share/man/man1" \
+ BINDIR="${D}usr/bin/" \
+ install || die "make install failed"
+
+ dodoc TODO NEWS CREDITS
+}