summaryrefslogtreecommitdiff
path: root/x11-misc/xsensors
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xsensors
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xsensors')
-rw-r--r--x11-misc/xsensors/Manifest1
-rw-r--r--x11-misc/xsensors/files/xsensors-0.70-gtk220.patch38
-rw-r--r--x11-misc/xsensors/metadata.xml5
-rw-r--r--x11-misc/xsensors/xsensors-0.70.ebuild36
4 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/xsensors/Manifest b/x11-misc/xsensors/Manifest
new file mode 100644
index 00000000000..6ca8e226768
--- /dev/null
+++ b/x11-misc/xsensors/Manifest
@@ -0,0 +1 @@
+DIST xsensors-0.70.tar.gz 115430 SHA256 907f21afd19fe88b70f000d6531ddcd53569ba0c0712e2b0afaab3fd9ca637ea
diff --git a/x11-misc/xsensors/files/xsensors-0.70-gtk220.patch b/x11-misc/xsensors/files/xsensors-0.70-gtk220.patch
new file mode 100644
index 00000000000..0aaf2c8026b
--- /dev/null
+++ b/x11-misc/xsensors/files/xsensors-0.70-gtk220.patch
@@ -0,0 +1,38 @@
+--- src/gui.c
++++ src/gui.c
+@@ -84,7 +84,7 @@
+ while ( *digit ) {
+ get_pm_location( *digit, &x, &y, &w );
+ gdk_draw_drawable( widget->window,
+- widget->style->fg_gc[ GTK_WIDGET_STATE
++ widget->style->fg_gc[ gtk_widget_get_state
+ (widget) ], theme, x, y + highLow,
+ pos, 0, w, 30 );
+ pos += w;
+@@ -121,7 +121,7 @@
+
+ /* Display RPM */
+ gdk_draw_drawable( widget->window,
+- widget->style->fg_gc[ GTK_WIDGET_STATE
++ widget->style->fg_gc[ gtk_widget_get_state
+ (widget) ], theme, 0, 120 + highLow,
+ 90, 0, 57, 30 );
+ break;
+@@ -142,7 +142,7 @@
+ else
+ x = 57;
+ gdk_draw_drawable( widget->window,
+- widget->style->fg_gc[ GTK_WIDGET_STATE
++ widget->style->fg_gc[ gtk_widget_get_state
+ (widget) ], theme, x, 60 + highLow,
+ 96, 0, 57, 30 );
+
+@@ -158,7 +158,7 @@
+
+ /* Display V */
+ gdk_draw_drawable( widget->window,
+- widget->style->fg_gc[ GTK_WIDGET_STATE
++ widget->style->fg_gc[ gtk_widget_get_state
+ (widget) ], theme, 114, 60 + highLow,
+ 96, 0, 57, 30 );
+
diff --git a/x11-misc/xsensors/metadata.xml b/x11-misc/xsensors/metadata.xml
new file mode 100644
index 00000000000..73122504865
--- /dev/null
+++ b/x11-misc/xsensors/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xsensors/xsensors-0.70.ebuild b/x11-misc/xsensors/xsensors-0.70.ebuild
new file mode 100644
index 00000000000..badf480b1fb
--- /dev/null
+++ b/x11-misc/xsensors/xsensors-0.70.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="A hardware health information viewer, interface to lm-sensors"
+HOMEPAGE="http://www.linuxhardware.org/xsensors/"
+SRC_URI="http://www.linuxhardware.org/xsensors/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=sys-apps/lm_sensors-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk220.patch
+
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ -e 's:-Werror:-Wall:' \
+ src/Makefile.am configure.in || die
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+}