summaryrefslogtreecommitdiff
path: root/x11-misc/xsri
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xsri
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xsri')
-rw-r--r--x11-misc/xsri/Manifest1
-rw-r--r--x11-misc/xsri/files/xsri-2.1.0-configure.patch26
-rw-r--r--x11-misc/xsri/metadata.xml5
-rw-r--r--x11-misc/xsri/xsri-2.1.0-r3.ebuild29
4 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/xsri/Manifest b/x11-misc/xsri/Manifest
new file mode 100644
index 00000000000..889b14f18ca
--- /dev/null
+++ b/x11-misc/xsri/Manifest
@@ -0,0 +1 @@
+DIST xsri-2.1.0-17.fc12.src.rpm 79266 SHA256 0fc0d459de22ea28ada1d4059ee9487a194fa2e35e38fd07bcb75c946586a95b SHA512 1e0948b4f03eef797fdef63732f592ebaa3aeff7010941c2df9ae0a3656a9c477adad48c72cf59531227f2427330cca13ae09c5c60739ec66411dcce10f44ee9 WHIRLPOOL a3b08d710f37eb7b743cb5a53b313c2a8db4c5caf6e0a43f3e1ddce697db7466a0d2da480a66e600de6432aca1913babe05c70d48519e3e3fd76dd3ee91b905a
diff --git a/x11-misc/xsri/files/xsri-2.1.0-configure.patch b/x11-misc/xsri/files/xsri-2.1.0-configure.patch
new file mode 100644
index 00000000000..c000e709109
--- /dev/null
+++ b/x11-misc/xsri/files/xsri-2.1.0-configure.patch
@@ -0,0 +1,26 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,8 +1,5 @@
+ INCLUDES = \
+ $(GTK_CFLAGS) \
+- -DG_DISABLE_DEPRECATED \
+- -DGDK_DISABLE_DEPRECATED \
+- -DGTK_DISABLE_DEPRECATED \
+ -DSYSCONFDIR=\"$(sysconfdir)\"
+
+ bin_PROGRAMS = xsri
+--- a/configure.in
++++ b/configure.in
+@@ -26,9 +26,11 @@
+
+ dnl library checks (not using macros/ directory)
+
+-PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 1.3.13,,
++PKG_CHECK_MODULES(GTK, x11 gtk+-2.0 >= 1.3.13,,
+ AC_MSG_ERROR([*** GTK+-2.0 must be installed to compile xsri]))
+
++AC_CHECK_LIB(m, sqrt)
++
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
diff --git a/x11-misc/xsri/metadata.xml b/x11-misc/xsri/metadata.xml
new file mode 100644
index 00000000000..40838bc3678
--- /dev/null
+++ b/x11-misc/xsri/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xsri/xsri-2.1.0-r3.ebuild b/x11-misc/xsri/xsri-2.1.0-r3.ebuild
new file mode 100644
index 00000000000..4bfd7d42a4f
--- /dev/null
+++ b/x11-misc/xsri/xsri-2.1.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils rpm
+
+DESCRIPTION="The xsri wallpaper setter from RedHat"
+HOMEPAGE="http://fedoraproject.org"
+SRC_URI="http://download.fedoraproject.org/pub/fedora/linux/releases/15/Everything/source/SRPMS/${P}-17.fc12.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README
+ doman ../${PN}.1
+}