summaryrefslogtreecommitdiff
path: root/x11-misc/xssstate
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xssstate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xssstate')
-rw-r--r--x11-misc/xssstate/Manifest1
-rw-r--r--x11-misc/xssstate/files/xssstate-1.0.20130103-gentoo.patch89
-rw-r--r--x11-misc/xssstate/metadata.xml10
-rw-r--r--x11-misc/xssstate/xssstate-1.1.ebuild36
4 files changed, 136 insertions, 0 deletions
diff --git a/x11-misc/xssstate/Manifest b/x11-misc/xssstate/Manifest
new file mode 100644
index 00000000000..5e0d2e9d8b3
--- /dev/null
+++ b/x11-misc/xssstate/Manifest
@@ -0,0 +1 @@
+DIST xssstate-1.1.tar.gz 3725 SHA256 c4b6f504a6a8eb247bc60960bd65cbf9631c008449a1d71ac4c55e34be1c6011 SHA512 96c59e9cc7b78aec8a95040cd1c4c6aaeb85f092c5a52cf64a62ceeb3fed65bdd3eb6f070b3d66ae8ec2544371a236f32e83e0a5c45e6d21f2bf7791b5c0d519 WHIRLPOOL a4325df86a593530975c758446d496d3815aab606bed0f768f52365438aa25339498cc32cd7b5d4e7a4a72e99649b388be2c3f3a9c2bdb093915f3e2ac750144
diff --git a/x11-misc/xssstate/files/xssstate-1.0.20130103-gentoo.patch b/x11-misc/xssstate/files/xssstate-1.0.20130103-gentoo.patch
new file mode 100644
index 00000000000..b951afe91a8
--- /dev/null
+++ b/x11-misc/xssstate/files/xssstate-1.0.20130103-gentoo.patch
@@ -0,0 +1,89 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,7 @@
+ SRC = xssstate.c
+ OBJ = ${SRC:.c=.o}
+
+-all: options xssstate
++all: xssstate
+
+ options:
+ @echo xssstate build options:
+@@ -14,42 +14,34 @@
+ @echo "CC = ${CC}"
+
+ .c.o:
+- @echo CC $<
+- @${CC} -c ${CFLAGS} $<
++ ${CC} -c ${CFLAGS} $<
+
+ ${OBJ}: config.mk
+
+-xssstate: xssstate.o
+- @echo CC -o $@
+- @${CC} -o $@ xssstate.o ${LDFLAGS}
++xssstate: options xssstate.o
++ ${CC} -o $@ xssstate.o ${LDFLAGS}
+
+ clean:
+- @echo cleaning
+ @rm -f xssstate ${OBJ} xssstate-${VERSION}.tar.gz
+
+ dist: clean
+- @echo creating dist tarball
+- @mkdir -p xssstate-${VERSION}
+- @cp -R LICENSE README Makefile config.mk xsidle.sh \
++ mkdir -p xssstate-${VERSION}
++ cp -R LICENSE README Makefile config.mk xsidle.sh \
+ xssstate.1 arg.h ${SRC} xssstate-${VERSION}
+- @tar -cf xssstate-${VERSION}.tar xssstate-${VERSION}
+- @gzip xssstate-${VERSION}.tar
+- @rm -rf xssstate-${VERSION}
++ tar -cf xssstate-${VERSION}.tar xssstate-${VERSION}
++ gzip xssstate-${VERSION}.tar
++ rm -rf xssstate-${VERSION}
+
+ install: all
+- @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+- @mkdir -p ${DESTDIR}${PREFIX}/bin
+- @cp -f xssstate ${DESTDIR}${PREFIX}/bin
+- @chmod 755 ${DESTDIR}${PREFIX}/bin/xssstate
+- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+- @sed "s/VERSION/${VERSION}/g" < xssstate.1 > ${DESTDIR}${MANPREFIX}/man1/xssstate.1
+- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/xssstate.1
++ mkdir -p ${DESTDIR}${PREFIX}/bin
++ cp -f xssstate ${DESTDIR}${PREFIX}/bin
++ chmod 755 ${DESTDIR}${PREFIX}/bin/xssstate
++# mkdir -p ${DESTDIR}${MANPREFIX}/man1
++# @sed "s/VERSION/${VERSION}/g" < xssstate.1 > ${DESTDIR}${MANPREFIX}/man1/xssstate.1
++# @chmod 644 ${DESTDIR}${MANPREFIX}/man1/xssstate.1
+
+ uninstall:
+- @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+- @rm -f ${DESTDIR}${PREFIX}/bin/xssstate
+- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+- @rm -f ${DESTDIR}${MANPREFIX}/man1/xssstate.1
++ rm -f ${DESTDIR}${PREFIX}/bin/xssstate
++# @rm -f ${DESTDIR}${MANPREFIX}/man1/xssstate.1
+
+ .PHONY: all options clean dist install uninstall
+--- a/config.mk
++++ b/config.mk
+@@ -13,13 +13,13 @@
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\"
+-CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+-LDFLAGS = -g ${LIBS}
++CFLAGS += -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
++LDFLAGS += ${LIBS}
+
+ # Solaris
+ #CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = ${LIBS}
+
+ # compiler and linker
+-CC = cc
++CC ?= cc
+
diff --git a/x11-misc/xssstate/metadata.xml b/x11-misc/xssstate/metadata.xml
new file mode 100644
index 00000000000..d6e0a0f7ede
--- /dev/null
+++ b/x11-misc/xssstate/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+<maintainer>
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-misc/xssstate/xssstate-1.1.ebuild b/x11-misc/xssstate/xssstate-1.1.ebuild
new file mode 100644
index 00000000000..460229ec0b2
--- /dev/null
+++ b/x11-misc/xssstate/xssstate-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A simple tool to retrieve the X screensaver state"
+HOMEPAGE="http://tools.suckless.org/xssstate"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/scrnsaverproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.20130103-gentoo.patch
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX='/usr' install
+ dodoc README xsidle.sh
+ doman ${PN}.1
+}