summaryrefslogtreecommitdiff
path: root/x11-plugins/cputnik
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/cputnik
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/cputnik')
-rw-r--r--x11-plugins/cputnik/Manifest1
-rw-r--r--x11-plugins/cputnik/cputnik-0.2.0.ebuild37
-rw-r--r--x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch24
-rw-r--r--x11-plugins/cputnik/metadata.xml5
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-plugins/cputnik/Manifest b/x11-plugins/cputnik/Manifest
new file mode 100644
index 00000000000..fb909c83c0f
--- /dev/null
+++ b/x11-plugins/cputnik/Manifest
@@ -0,0 +1 @@
+DIST cputnik-0.2.0.tar.gz 17850 SHA256 b8a11fbfc5b1ce60cf8b50ad94e395aedf31c81d43ea1a0f277c4cac5c8b61df SHA512 829d9d63f82a2d41c0160be575b3fb7840a5c295c6dd16702240a6aa104e557bff83936c46243e850edf918b41ddc22fd123dab7f5ffd6492302d60c374df55f WHIRLPOOL a30221c4a1d69aac95510acbb8ccae905d9e0729150f8ce7fb7e61c0761158a1d8ef8680a1b8236235d9ca7e379ceca4ca8d45c7b75e9adbaca847ef73d951d4
diff --git a/x11-plugins/cputnik/cputnik-0.2.0.ebuild b/x11-plugins/cputnik/cputnik-0.2.0.ebuild
new file mode 100644
index 00000000000..c7d9c1b4316
--- /dev/null
+++ b/x11-plugins/cputnik/cputnik-0.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="cputnik is a simple cpu monitor dockapp"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/273"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/576/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Compilation failed"
+}
+
+src_install() {
+ dobin cputnik || die "dobin failed."
+ dodoc ../{AUTHORS,NEWS,README}
+}
diff --git a/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch b/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch
new file mode 100644
index 00000000000..1eb1279b3bb
--- /dev/null
+++ b/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch
@@ -0,0 +1,24 @@
+--- Makefile.orig 2005-03-26 22:29:48.000000000 +0100
++++ Makefile 2008-01-27 19:43:33.000000000 +0100
+@@ -1,15 +1,15 @@
+
+-CFLAGS = -Wall -Os
+-INCS = -I/usr/X11R6/include/X11
+-LIBS = -L/usr/X11R6/lib -lXpm -lXext -lX11
+-INSTALL_PREFIX = /usr/local
++CFLAGS += -Wall
++INCS = -I/usr/include/X11
++LIBS = -L/usr/lib -lXpm -lXext -lX11
++INSTALL_PREFIX = /usr
+
+
+ all: cputnik.c docklib.o master.h mask.h
+- gcc $(CFLAGS) $(INCS) docklib.o cputnik.c -o cputnik $(LIBS)
++ $(CC) $(CFLAGS) $(INCS) docklib.o cputnik.c -o cputnik $(LDFLAGS) $(LIBS)
+
+ docklib.o: docklib.c docklib.h
+- gcc $(CFLAGS) $(INCS) -c docklib.c
++ $(CC) $(CFLAGS) $(INCS) -c docklib.c
+
+ install:
+ cp ./cputnik $(INSTALL_PREFIX)/bin
diff --git a/x11-plugins/cputnik/metadata.xml b/x11-plugins/cputnik/metadata.xml
new file mode 100644
index 00000000000..b1a9efc4f2f
--- /dev/null
+++ b/x11-plugins/cputnik/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>