summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellkam
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrellkam
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrellkam')
-rw-r--r--x11-plugins/gkrellkam/Manifest1
-rw-r--r--x11-plugins/gkrellkam/files/gkrellkam-2.0.0-makefile.patch25
-rw-r--r--x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild36
-rw-r--r--x11-plugins/gkrellkam/metadata.xml8
4 files changed, 70 insertions, 0 deletions
diff --git a/x11-plugins/gkrellkam/Manifest b/x11-plugins/gkrellkam/Manifest
new file mode 100644
index 00000000000..ff6c84e8c74
--- /dev/null
+++ b/x11-plugins/gkrellkam/Manifest
@@ -0,0 +1 @@
+DIST gkrellkam_2.0.0.tar.gz 27028 SHA256 4d0c208c3654f54c0ff6b3e87d1f046d21415b73266e5aa053a77173507e460f SHA512 a5a5d0a41de37b006c42150f0388ba573c968679f3f15c6b1d4837361d136cb529c2152723382e99bb46a76be5f1bde641137cea22e07a502402560dcd18699f WHIRLPOOL c1e8c6a6728b7eeff80d00b8c8596817065469e3da0631b761e9aa4b105bd04331f0c07ceb0dedc9af4acd9f70583ffc2355f8e9824a8efa2bbfbca960bd9f43
diff --git a/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-makefile.patch b/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-makefile.patch
new file mode 100644
index 00000000000..83178b4b0ff
--- /dev/null
+++ b/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-makefile.patch
@@ -0,0 +1,25 @@
+--- Makefile 2002-10-23 18:36:20.000000000 +0200
++++ Makefile_new 2013-03-16 14:02:42.979029588 +0100
+@@ -12,10 +12,10 @@
+ # This should point to the GKrellM headers
+ GKRELLM_HDRS = /usr/include
+
+-CC := gcc
++CC = $(CC)
+ GTKFLAGS := $(shell pkg-config gtk+-2.0 --cflags)
+-CFLAGS := $(CFLAGS) -fPIC -Wall $(GTKFLAGS) -I$(GKRELLM_HDRS)
+-LDFLAGS := -shared -Wl
++CFLAGS := $(CFLAGS) -fPIC $(GTKFLAGS) -I$(GKRELLM_HDRS)
++LFLAGS = -shared
+ INST_DIR := $(DESTDIR)/usr/lib/gkrellm2/plugins
+ USER_INST_DIR := $(DESTDIR)$(HOME)/.gkrellm2/plugins
+ MANPAGES := gkrellkam-list.5
+@@ -26,7 +26,7 @@
+ all: $(TARGET).so
+
+ %.so: %.o
+- $(CC) $(LDFLAGS) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LFLAGS) -o $@ $<
+
+ clean:
+ -rm -f $(TARGET).so $(TARGET).o
diff --git a/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild b/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
new file mode 100644
index 00000000000..688e83c63db
--- /dev/null
+++ b/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils gkrellm-plugin toolchain-funcs
+
+MY_P=${P/-/_}
+
+DESCRIPTION="an Image-Watcher-Plugin for GKrellM2"
+SRC_URI="mirror://sourceforge/gkrellkam/${MY_P}.tar.gz"
+HOMEPAGE="http://gkrellkam.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="x86 ppc sparc alpha amd64"
+
+RDEPEND="net-misc/wget
+ app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
+
+PLUGIN_SO=gkrellkam2.so
+PLUGIN_DOCS="example.list"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ gkrellm-plugin_src_install
+ doman gkrellkam-list.5
+}
diff --git a/x11-plugins/gkrellkam/metadata.xml b/x11-plugins/gkrellkam/metadata.xml
new file mode 100644
index 00000000000..58edd8f67a5
--- /dev/null
+++ b/x11-plugins/gkrellkam/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">gkrellkam</remote-id>
+ </upstream>
+</pkgmetadata>