summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-imonc
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-07 00:06:55 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-07 00:07:13 -0400
commit51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46 (patch)
tree87ee66d099783dbc1cfc6d2fcc70f2a170775904 /x11-plugins/gkrellm-imonc
parentda44b89f707022c20e6e370b9b0592fd3773584f (diff)
downloadgentoo-51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46.tar.gz
gentoo-51d8d2f1eaf8ca67459dddeed5dc6ce584fc1a46.tar.xz
x11-plugins/gkrellm-imonc: new revision that respects LDFLAGS.
This is another revision thanks to Michael Mair-Keimberger. His patch fixes the Makefile so that it adds $(LDFLAGS) in the right spots, and also happens to fix $(CC) in the process. An EAPI=2 USE-dependency was added for gkrellm (also part of the patch), and the ebuild was updated to use EAPI=6. Gentoo-Bug: 335013 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/gkrellm-imonc')
-rw-r--r--x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch35
-rw-r--r--x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild29
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch b/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch
new file mode 100644
index 00000000000..598e5d8460c
--- /dev/null
+++ b/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch
@@ -0,0 +1,35 @@
+--- a/Makefile 2003-05-17 20:08:29.000000000 +0200
++++ b/Makefile 2013-03-13 18:24:24.552941672 +0100
+@@ -9,12 +9,10 @@
+ GTK_INCLUDE = $(shell pkg-config gtk+-2.0 --cflags)
+ GTK_LIB = $(shell pkg-config gtk+-2.0 --libs)
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
++FLAGS = -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+
+-LFLAGS = -shared
+-
+-CC = gcc
++LFLAGS = -shared
+
+ #
+ # files
+@@ -30,7 +28,7 @@
+
+
+ %.o : %.c
+- $(CC) $(CFLAGS) $(FLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) -c $< -o $@
+
+
+ all:
+@@ -41,7 +39,7 @@
+
+ $(TARGET): $(OBJECTS)
+ @echo -e "\n\n>> linking\n"
+- $(CC) $(OBJECTS) -o $@ $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJECTS) -o $@ $(LFLAGS) $(LIBS)
+ @echo -e "\n<< done "
+
+ install: gkrellm-imonc.so
diff --git a/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild
new file mode 100644
index 00000000000..856afe740e9
--- /dev/null
+++ b/x11-plugins/gkrellm-imonc/gkrellm-imonc-0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gkrellm-plugin
+
+DESCRIPTION="A GKrellM2 plugin to control a fli4l router"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tar.bz2"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+
+# The COPYING file contains the GPLv2, but the file headers say GPLv2+.
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="app-admin/gkrellm[X]"
+DEPEND+=" ${COMMON_DEPEND}"
+RDEPEND+=" ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}