summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellsun
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-05 19:21:12 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-05 19:32:09 -0400
commit9c32c73de5c993525bdf76535b94f32b9a6b2635 (patch)
treeb99186b18b2cf076abe5d42b7f5fb671e37dad1e /x11-plugins/gkrellsun
parent8b9da2f3f46654c66a7d8ebdab869aa7433818a9 (diff)
downloadgentoo-9c32c73de5c993525bdf76535b94f32b9a6b2635.tar.gz
gentoo-9c32c73de5c993525bdf76535b94f32b9a6b2635.tar.xz
x11-plugins/gkrellsun: new revision with EAPI=6.
This new revision updates to EAPI=6 for a few reasons. First, the old EAPI in use was deprecated. There is also a faked USE dependency in the eclass (reported in bug 514108) that was turnen into a real one. Finally, the default src_prepare was adopted. Gentoo-Bug: 514108 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/gkrellsun')
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
new file mode 100644
index 00000000000..200303e0b92
--- /dev/null
+++ b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gkrellm-plugin
+
+DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times"
+HOMEPAGE="http://gkrellsun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+COMMON_DEPEND="app-admin/gkrellm[X]
+ nls? ( sys-devel/gettext )"
+DEPEND+=" ${COMMON_DEPEND}"
+RDEPEND+=" ${COMMON_DEPEND}"
+
+PLUGIN_SO=src20/gkrellsun.so
+
+PATCHES=(
+ "${FILESDIR}/${P}-reenable.patch"
+ "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+)
+
+src_compile() {
+ use nls && myconf="$myconf enable_nls=1"
+ emake ${myconf}
+}