summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-xmpp-receipts
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/pidgin-xmpp-receipts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/pidgin-xmpp-receipts')
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/Manifest1
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/metadata.xml8
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-xmpp-receipts/Manifest b/x11-plugins/pidgin-xmpp-receipts/Manifest
new file mode 100644
index 00000000000..217e00f333a
--- /dev/null
+++ b/x11-plugins/pidgin-xmpp-receipts/Manifest
@@ -0,0 +1 @@
+DIST pidgin-xmpp-receipts-0.6.tar.gz 15946 SHA256 a7aa5ab7375dc996d769dd83fdf6f7c68ac6ef9fd25cfb04eb7bf2becd381174 SHA512 160270206d0d6394bddaa15ca59896756ab3a546f7c74cc9e3d4ec634f70b829ae3b013ee6086a5d4a5376b7d2b81341c44c3ef0ecab2a66d612b96fd37dfeff WHIRLPOOL 00349394518cb44d3a25c0ed66b0e0446ca9bdeddb68b818e1c4b493e38ee22a550d27e4a9170360f73c9ec449a8602c2ab2a0f451411862e32cd33d8782a94f
diff --git a/x11-plugins/pidgin-xmpp-receipts/metadata.xml b/x11-plugins/pidgin-xmpp-receipts/metadata.xml
new file mode 100644
index 00000000000..bfcb6974f1c
--- /dev/null
+++ b/x11-plugins/pidgin-xmpp-receipts/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild
new file mode 100644
index 00000000000..53e421914e1
--- /dev/null
+++ b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Implementation of xmpp message delivery receipts (XEP-0184) for Pidgin"
+HOMEPAGE="https://www.assembla.com/spaces/pidgin-xmpp-receipts/documents"
+SRC_URI="https://www.assembla.com/spaces/pidgin-xmpp-receipts/documents/ckA6jCV5Kr4OkjacwqjQXA/download/ckA6jCV5Kr4OkjacwqjQXA -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ GTK_PIDGIN_INCLUDES=$(pkg-config --cflags gtk+-2.0 pidgin)
+ $(tc-getCC) ${LDFLAGS} -shared ${CFLAGS} -fpic ${GTK_PIDGIN_INCLUDES} -o ${PN/pidgin-/}.so ${PN/pidgin-/}.c || die
+}
+
+src_install() {
+ PLUGIN_DIR_PIDGIN=$(pkg-config --variable=plugindir pidgin)
+ dodir "${PLUGIN_DIR_PIDGIN}"
+ insinto "${PLUGIN_DIR_PIDGIN}"
+ doins ${PN/pidgin-/}.so
+}