summaryrefslogtreecommitdiff
path: root/x11-plugins/purple-facebook
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/purple-facebook
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/purple-facebook')
-rw-r--r--x11-plugins/purple-facebook/Manifest2
-rw-r--r--x11-plugins/purple-facebook/metadata.xml11
-rw-r--r--x11-plugins/purple-facebook/purple-facebook-20150727.ebuild31
-rw-r--r--x11-plugins/purple-facebook/purple-facebook-20150728.ebuild31
4 files changed, 75 insertions, 0 deletions
diff --git a/x11-plugins/purple-facebook/Manifest b/x11-plugins/purple-facebook/Manifest
new file mode 100644
index 00000000000..a6314c89b51
--- /dev/null
+++ b/x11-plugins/purple-facebook/Manifest
@@ -0,0 +1,2 @@
+DIST purple-facebook-20150727.tar.gz 427255 SHA256 141abe779c9dd3be31bdc0e66455908e53da0dfdda4ef558511c22bc03265439 SHA512 5ee762bf0164d4c889e04f794eb6592b7a04387a54da3a969099fa1850c073b80a47ec3ae82bae23c8990c262022dfcc6a92b9a8ff3d3bd700a0975f122a8fde WHIRLPOOL 567b5349e89769b27f3b25193fa226473b8442e911989a5d69c3608a808727568b09d5e45af8e36e5c3cab5c0f8707e6c267df9553af34ed1976b2bacbbc29d3
+DIST purple-facebook-20150728.tar.gz 427451 SHA256 4ad2c53f1744020feb56e7626b39453b0ad6b1e449a52c2b74ca5d2d1f3dc0fa SHA512 144b34053c74f98ac556c1215fdec8e44764a1d69562bab64858a2d60157f6cb0af4d4571a93dcbf949033a6a40b870e0b2a2154fdfa448ecca22dab9d83f810 WHIRLPOOL c720b0ab8936e61c9e9c7c2128ee9ccdec2f91836b6bbf0dc03c47ccae143b5831d5d9cecadfbd9e536a0e320f365568fa030256eec4fd3b2a882da23ec8cdfd
diff --git a/x11-plugins/purple-facebook/metadata.xml b/x11-plugins/purple-facebook/metadata.xml
new file mode 100644
index 00000000000..08ea18cd1cf
--- /dev/null
+++ b/x11-plugins/purple-facebook/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jgeboski/purple-facebook</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/purple-facebook/purple-facebook-20150727.ebuild b/x11-plugins/purple-facebook/purple-facebook-20150727.ebuild
new file mode 100644
index 00000000000..b3f3fb0c892
--- /dev/null
+++ b/x11-plugins/purple-facebook/purple-facebook-20150727.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+MY_PV="f80258f7ce6f"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="Facebook protocol plugin for libpurple"
+HOMEPAGE="https://github.com/jgeboski/purple-facebook"
+SRC_URI="https://github.com/jgeboski/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/json-glib
+ net-im/pidgin"
+DEPEND="${RDEPEND}"
+DOCS=( AUTHORS ChangeLog NEWS README VERSION )
+
+src_configure() {
+ econf --with-ssl-certs
+}
+
+src_prepare() {
+ eautoreconf
+}
diff --git a/x11-plugins/purple-facebook/purple-facebook-20150728.ebuild b/x11-plugins/purple-facebook/purple-facebook-20150728.ebuild
new file mode 100644
index 00000000000..ac74ccd869c
--- /dev/null
+++ b/x11-plugins/purple-facebook/purple-facebook-20150728.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+MY_PV="7c454f51b56b"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="Facebook protocol plugin for libpurple"
+HOMEPAGE="https://github.com/jgeboski/purple-facebook"
+SRC_URI="https://github.com/jgeboski/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/json-glib
+ net-im/pidgin"
+DEPEND="${RDEPEND}"
+DOCS=( AUTHORS ChangeLog NEWS README VERSION )
+
+src_configure() {
+ econf --with-ssl-certs
+}
+
+src_prepare() {
+ eautoreconf
+}