summaryrefslogtreecommitdiff
path: root/x11-plugins/wmacpimon/files/Makefile.patch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmacpimon/files/Makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmacpimon/files/Makefile.patch')
-rw-r--r--x11-plugins/wmacpimon/files/Makefile.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-plugins/wmacpimon/files/Makefile.patch b/x11-plugins/wmacpimon/files/Makefile.patch
new file mode 100644
index 00000000000..aab28fc8939
--- /dev/null
+++ b/x11-plugins/wmacpimon/files/Makefile.patch
@@ -0,0 +1,24 @@
+--- Makefile 2010-09-06 11:33:16.000000000 +0200
++++ Makefile.new 2010-09-06 11:36:28.000000000 +0200
+@@ -1,8 +1,5 @@
+-OPT = -O3 -DACPI
+-
+-CC = gcc
+-CFLAGS = $(OPT) -Wall -I/usr/X11R6/include
+-LDFLAGS = $(OPT) -L/usr/X11R6/lib -lX11 -lXpm -lXext
++CFLAGS += -DACPI -Wall -I/usr/X11R6/include
++LIBS = -DACPI -L/usr/X11R6/lib -lX11 -lXpm -lXext
+
+ SRCS = wmacpimon.c libacpi.c
+ OBJS = wmacpimon.o libacpi.o
+@@ -11,8 +8,10 @@
+ all: wmacpimon wmacpimond
+
+ wmacpimon: $(OBJS)
++ $(CC) $(LDFLAGS) -o wmacpimon $^ $(LIBS)
+
+ wmacpimond: $(OBJZ)
++ $(CC) $(LDFLAGS) -o wmacpimond $^ $(LIBS)
+
+ clean:
+ rm -f *.o *~ wmacpimon wmacpimond trace *.out *.bb *.bbg