summaryrefslogtreecommitdiff
path: root/x11-plugins/wmlaptop
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmlaptop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmlaptop')
-rw-r--r--x11-plugins/wmlaptop/Manifest2
-rw-r--r--x11-plugins/wmlaptop/files/wmlaptop-ACPI-detection.patch24
-rw-r--r--x11-plugins/wmlaptop/files/wmlaptop-Makefile.patch32
-rw-r--r--x11-plugins/wmlaptop/files/wmlaptop.desktop8
-rw-r--r--x11-plugins/wmlaptop/metadata.xml5
-rw-r--r--x11-plugins/wmlaptop/wmlaptop-1.3.ebuild46
-rw-r--r--x11-plugins/wmlaptop/wmlaptop-1.4.ebuild46
7 files changed, 163 insertions, 0 deletions
diff --git a/x11-plugins/wmlaptop/Manifest b/x11-plugins/wmlaptop/Manifest
new file mode 100644
index 00000000000..9d0e4dc49c4
--- /dev/null
+++ b/x11-plugins/wmlaptop/Manifest
@@ -0,0 +1,2 @@
+DIST wmlaptop-1.3.tar.bz2 54575 SHA256 5ce0ad86ebbf1e8167d0e7eb020389393cf08bd3c849dba9fce383d95a55281f
+DIST wmlaptop-1.4.tar.gz 77023 SHA256 3a6a2900489555606e2dd411963c659edb43613877de85c67dab14f0c8a47c2c
diff --git a/x11-plugins/wmlaptop/files/wmlaptop-ACPI-detection.patch b/x11-plugins/wmlaptop/files/wmlaptop-ACPI-detection.patch
new file mode 100644
index 00000000000..802e6f09a75
--- /dev/null
+++ b/x11-plugins/wmlaptop/files/wmlaptop-ACPI-detection.patch
@@ -0,0 +1,24 @@
+diff -ru wmlaptop-1.4.orig/src/battery.c wmlaptop-1.4/src/battery.c
+--- wmlaptop-1.4.orig/src/battery.c 2010-11-26 14:26:27.594108155 -0600
++++ wmlaptop-1.4/src/battery.c 2010-11-26 14:26:51.324108155 -0600
+@@ -74,7 +74,7 @@
+
+ bool ACPI_canSupport( )
+ {
+- if( access( ACPI_ACCESS_TEST, R_OK ) == SUCCESS )
++ if( access( ACPI_ACCESS_TEST, R_OK | X_OK ) == SUCCESS )
+ return true;
+ return false;
+ }
+diff -ru wmlaptop-1.4.orig/src/battery.h wmlaptop-1.4/src/battery.h
+--- wmlaptop-1.4.orig/src/battery.h 2010-11-26 14:26:27.594108155 -0600
++++ wmlaptop-1.4/src/battery.h 2010-11-26 14:26:56.100774821 -0600
+@@ -24,7 +24,7 @@
+ /*******************
+ * ACPI FEATURES *
+ *********************************************************************************/
+-#define ACPI_ACCESS_TEST "/proc/acpi/info"
++#define ACPI_ACCESS_TEST "/proc/acpi"
+ #define ACPI_BATTERY_DIR "/proc/acpi/battery"
+ //TODO #define ACPI_BATTERY_DIR "/home/mtc/hisBattery/battery"
+
diff --git a/x11-plugins/wmlaptop/files/wmlaptop-Makefile.patch b/x11-plugins/wmlaptop/files/wmlaptop-Makefile.patch
new file mode 100644
index 00000000000..ab1148ce117
--- /dev/null
+++ b/x11-plugins/wmlaptop/files/wmlaptop-Makefile.patch
@@ -0,0 +1,32 @@
+--- /Makefile 2010-09-09 13:44:07.000000000 +0200
++++ /Makefile.new 2010-09-09 13:47:40.000000000 +0200
+@@ -1,14 +1,17 @@
+-
++LIBDIR = -L/usr/X11R6/lib
++LIBS = -lXpm -lXext -lX11
++OBJS = main.o init.o event.o draw.o battery.o cpu.o autoscript.o pixmap.o
++EXE = wmlaptop
+
+
+ .c.o:
+- $(CC) -c $< -o $*.o $(CFLAGS)
++ $(CC) $(CFLAGS) -c $< -o $*.o
+
+ all: $(EXE)
+
+ $(EXE): $(OBJS)
+ ./buildCounter
+- $(CC) -o $(EXE) $^ $(LIBDIR) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(EXE) $^ $(LIBDIR) $(LIBS)
+
+
+ clean:
+@@ -20,7 +23,7 @@
+ reall: clean all
+
+ install:
+- /usr/bin/install -c -o 0 -g 0 -s -m 755 $(EXE) $(INSTALLDIR)/$(EXE)
++ /usr/bin/install -c -o 0 -g 0 -m 755 $(EXE) $(INSTALLDIR)/$(EXE)
+ chmod +s $(INSTALLDIR)/$(EXE)
+
+ uninstall:
diff --git a/x11-plugins/wmlaptop/files/wmlaptop.desktop b/x11-plugins/wmlaptop/files/wmlaptop.desktop
new file mode 100644
index 00000000000..39c8229953f
--- /dev/null
+++ b/x11-plugins/wmlaptop/files/wmlaptop.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=WmLaptop
+Comment=Laptop Monitor
+Comment[pl]=Monitor Dla Laptopa
+Exec=wmlaptop
+Type=Application
+Terminal=false
+Categories=System;Monitor;
diff --git a/x11-plugins/wmlaptop/metadata.xml b/x11-plugins/wmlaptop/metadata.xml
new file mode 100644
index 00000000000..b1a9efc4f2f
--- /dev/null
+++ b/x11-plugins/wmlaptop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
new file mode 100644
index 00000000000..ab3093c37ef
--- /dev/null
+++ b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+
+MY_P="${P}"
+S="${WORKDIR}/${MY_P}/src"
+
+DESCRIPTION="Dockapp for laptop users"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/474/${P}.tar.bz2"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/227"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ >=sys-apps/sed-4.1.5-r1"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-ACPI-detection.patch
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ einstall INSTALLDIR="${D}/usr/bin" || die "Installation failed"
+
+ dodoc ../AUTHORS ../README ../README.IT ../THANKS
+
+ domenu "${FILESDIR}/${PN}.desktop"
+}
diff --git a/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild b/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild
new file mode 100644
index 00000000000..39408b49c1f
--- /dev/null
+++ b/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+
+MY_P="${P}"
+S="${WORKDIR}/${MY_P}/src"
+
+DESCRIPTION="Dockapp for laptop users"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/509/${P}.tar.gz"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/227"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ >=sys-apps/sed-4.1.5-r1"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-ACPI-detection.patch
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ einstall INSTALLDIR="${D}/usr/bin" || die "Installation failed"
+
+ dodoc ../AUTHORS ../README ../README.IT ../THANKS
+
+ domenu "${FILESDIR}/${PN}.desktop"
+}