summaryrefslogtreecommitdiff
path: root/x11-plugins/wmsvencd/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmsvencd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmsvencd/files')
-rw-r--r--x11-plugins/wmsvencd/files/wmsvencd-compile.patch36
-rw-r--r--x11-plugins/wmsvencd/files/wmsvencd.desktop8
2 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/wmsvencd/files/wmsvencd-compile.patch b/x11-plugins/wmsvencd/files/wmsvencd-compile.patch
new file mode 100644
index 00000000000..1ab9a9f7e38
--- /dev/null
+++ b/x11-plugins/wmsvencd/files/wmsvencd-compile.patch
@@ -0,0 +1,36 @@
+diff -urN wmsvencd-0.5.0.orig/Makefile wmsvencd-0.5.0/Makefile
+--- wmsvencd-0.5.0.orig/Makefile 1999-05-08 09:54:08.000000000 +0200
++++ wmsvencd-0.5.0/Makefile 2003-09-18 03:56:41.448394312 +0200
+@@ -1,11 +1,13 @@
+ BINDIR = /usr/local/bin
+ MANDIR = /usr/local/man/man1
+ CFLAGS = -O6 -fno-strength-reduce
++LIBDIR = -L/usr/X11R6/lib
++LIBS = -lXpm -lXext -lX11
+
+ all: wmsvencd
+
+ wmsvencd: cdctl.o wmsvencd.o
+- c++ -o wmsvencd $(CFLAGS) -L/usr/X11R6/lib wmsvencd.o cdctl.o -lXpm -lXext -lX11
++ c++ -o wmsvencd $(CFLAGS) $(LIBDIR) wmsvencd.o cdctl.o $(LIBS)
+
+ wmsvencd.o: wmsvencd.cc
+ c++ $(CFLAGS) -I/usr/X11R6/include -I/include -c wmsvencd.cc -o wmsvencd.o
+@@ -21,4 +23,4 @@
+ install:
+ mkdir -p $(BINDIR)
+ install -c -s -m 0755 wmsvencd $(BINDIR)
+- install -c -m 0644 wmsvencd.1x $(MANDIR)
++ install -c -m 0644 wmsvencd.1x $(MANDIR)
+\ No newline at end of file
+diff -urN wmsvencd-0.5.0.orig/cdctl.cc wmsvencd-0.5.0/cdctl.cc
+--- wmsvencd-0.5.0.orig/cdctl.cc 1999-05-08 05:51:29.000000000 +0200
++++ wmsvencd-0.5.0/cdctl.cc 2003-09-18 03:55:06.393844800 +0200
+@@ -35,6 +35,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/x11-plugins/wmsvencd/files/wmsvencd.desktop b/x11-plugins/wmsvencd/files/wmsvencd.desktop
new file mode 100644
index 00000000000..755937301b1
--- /dev/null
+++ b/x11-plugins/wmsvencd/files/wmsvencd.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=WmSvenCD
+Comment=WindowMaker dockable CD-player with CDDB
+Comment[pl]=Dokowalny CD-player dla WindowMakera z obsługą CDDB
+Exec=wmsvencd
+Type=Application
+Terminal=false
+Categories=AudioVideo;Audio;