summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-01-04 13:35:13 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-01-04 13:56:48 +0100
commita611d0fe6871a320287aadbab9e0517bcd0c2660 (patch)
tree34032d7165687e55e109fdf9fbb1ba8ddb0634f9 /x11-plugins
parent6a6ce709cfce859fe40ea4d4cbe0d7f2c7e1365e (diff)
downloadgentoo-a611d0fe6871a320287aadbab9e0517bcd0c2660.tar.gz
gentoo-a611d0fe6871a320287aadbab9e0517bcd0c2660.tar.xz
x11-plugins/wmmon+smp: fix compilation with gcc 5, bug #569598
Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmon+smp/files/wmmon+smp-1.0-list.patch127
-rw-r--r--x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild8
2 files changed, 133 insertions, 2 deletions
diff --git a/x11-plugins/wmmon+smp/files/wmmon+smp-1.0-list.patch b/x11-plugins/wmmon+smp/files/wmmon+smp-1.0-list.patch
new file mode 100644
index 00000000000..1b1ac317669
--- /dev/null
+++ b/x11-plugins/wmmon+smp/files/wmmon+smp-1.0-list.patch
@@ -0,0 +1,127 @@
+diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
+--- wmgeneral.orig/list.c 2016-01-04 13:28:36.583339716 +0100
++++ wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
+@@ -38,7 +38,7 @@
+
+ /* Return a cons cell produced from (head . tail)
+
+-INLINE LinkedList*
++LinkedList*
+ list_cons(void* head, LinkedList* tail)
+ {
+ LinkedList* cell;
+@@ -51,7 +51,7 @@
+
+ /* Return the length of a list, list_length(NULL) returns zero
+
+-INLINE int
++int
+ list_length(LinkedList* list)
+ {
+ int i = 0;
+@@ -66,7 +66,7 @@
+ /* Return the Nth element of LIST, where N count from zero. If N
+ larger than the list length, NULL is returned
+
+-INLINE void*
++void*
+ list_nth(int index, LinkedList* list)
+ {
+ while(index-- != 0)
+@@ -81,7 +81,7 @@
+
+ /* Remove the element at the head by replacing it by its successor
+
+-INLINE void
++void
+ list_remove_head(LinkedList** list)
+ {
+ if (!*list) return;
+@@ -101,7 +101,7 @@
+
+ /* Remove the element with `car' set to ELEMENT
+ /*
+-INLINE void
++void
+ list_remove_elem(LinkedList** list, void* elem)
+ {
+ while (*list)
+@@ -112,7 +112,7 @@
+ }
+
+
+-INLINE LinkedList *
++LinkedList *
+ list_remove_elem(LinkedList* list, void* elem)
+ {
+ LinkedList *tmp;
+@@ -132,7 +132,7 @@
+
+ /* Return element that has ELEM as car
+
+-INLINE LinkedList*
++LinkedList*
+ list_find(LinkedList* list, void* elem)
+ {
+ while(list)
+@@ -146,7 +146,7 @@
+
+ /* Free list (backwards recursive)
+
+-INLINE void
++void
+ list_free(LinkedList* list)
+ {
+ if(list)
+@@ -158,7 +158,7 @@
+
+ /* Map FUNCTION over all elements in LIST
+
+-INLINE void
++void
+ list_mapcar(LinkedList* list, void(*function)(void*))
+ {
+ while(list)
+diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
+--- wmgeneral.orig/list.h 2016-01-04 13:28:36.583339716 +0100
++++ wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
+@@ -29,31 +29,25 @@
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
+-# define INLINE inline
+-#else
+-# define INLINE
+-#endif
+-
+ typedef struct LinkedList {
+ void *head;
+ struct LinkedList *tail;
+ } LinkedList;
+
+-INLINE LinkedList* list_cons(void* head, LinkedList* tail);
++LinkedList* list_cons(void* head, LinkedList* tail);
+
+-INLINE int list_length(LinkedList* list);
++int list_length(LinkedList* list);
+
+-INLINE void* list_nth(int index, LinkedList* list);
++void* list_nth(int index, LinkedList* list);
+
+-INLINE void list_remove_head(LinkedList** list);
++void list_remove_head(LinkedList** list);
+
+-INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
++LinkedList *list_remove_elem(LinkedList* list, void* elem);
+
+-INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
++void list_mapcar(LinkedList* list, void(*function)(void*));
+
+-INLINE LinkedList*list_find(LinkedList* list, void* elem);
++LinkedList*list_find(LinkedList* list, void* elem);
+
+-INLINE void list_free(LinkedList* list);
++void list_free(LinkedList* list);
+
+ #endif
diff --git a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild
index 8a3c94955f0..b630a918e3b 100644
--- a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild
+++ b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Dockapp CPU monitor resembling Xosview, support for smp"
SRC_URI="http://www.ne.jp/asahi/linux/timecop/wmmon+smp.tar.gz"
@@ -31,6 +31,10 @@ src_prepare() {
-e 's/cc -c/${CC} ${CFLAGS} -c/' \
-i Makefile || die
tc-export CC
+
+ cd "${WORKDIR}"/wmmon.app || die
+ ls
+ epatch "${FILESDIR}"/${P}-list.patch
}
src_install () {