summaryrefslogtreecommitdiff
path: root/x11-terms/kterm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/kterm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/kterm')
-rw-r--r--x11-terms/kterm/Manifest3
-rw-r--r--x11-terms/kterm/files/6.2.0-underline.patch22
-rw-r--r--x11-terms/kterm/files/kterm-6.2.0-Xaw3d.patch25
-rw-r--r--x11-terms/kterm/files/kterm-6.2.0-gentoo.patch51
-rw-r--r--x11-terms/kterm/files/kterm-6.2.0-openpty.patch59
-rw-r--r--x11-terms/kterm/files/kterm-ad-gentoo.diff21
-rw-r--r--x11-terms/kterm/kterm-6.2.0-r5.ebuild81
-rw-r--r--x11-terms/kterm/metadata.xml5
8 files changed, 267 insertions, 0 deletions
diff --git a/x11-terms/kterm/Manifest b/x11-terms/kterm/Manifest
new file mode 100644
index 00000000000..45f0257365e
--- /dev/null
+++ b/x11-terms/kterm/Manifest
@@ -0,0 +1,3 @@
+DIST kterm-6.2.0-wpi.patch.gz 6629 SHA256 f91f37ef8b9bf84ebfb24b26b43089af25f9756680cbf875320fda774de2b591 SHA512 b3ae44ce3a2a5ed7d08055c7b9a006844441c77727694ec1eb5f07752f745c8f1990ce23115070006999bd035fd934f09322bb6dc407f825f0da2b06a163faab WHIRLPOOL e9f8c3e8338118482f0debd341380fce7f2e9b8af8b7aa6284019a20581c389aad0c57242fe5ef706356edc4fa6efed2e515b3ccb1e4750dcefe22e967da6705
+DIST kterm-6.2.0.ext02.patch.gz 15290 SHA256 4501522c5632936b316ba820633cfa887192942e123a28b031d72b4d675c85eb SHA512 95b70f61496ed43dcbdda22b3250c651b3dbce07ef2209a7baec3f729ef954d6781dd5e18a5368d34792db4a3e310adec4fad5c05d3dfd211c0dc7f89c5ae356 WHIRLPOOL edb9f3ad01cbba27556a86450aba8f81c8b71505f54959bd462f2c081fcf4273a1b92aa36d8021da7c4ab1fec3df2eb8d89c9b2623ddcf03ee1c4c2977bab0bf
+DIST kterm-6.2.0.tar.gz 200448 SHA256 ecc965b926483cb97b74d1da5808359fac95d937dfa5e7338395988b1a3afaa5 SHA512 c84a5b57154dc14ab93e1bc6cd33103495716c203a648d57044672c4218cb7e4e80110f7e6e7c0900c80c2e55843ecb190de4f61d0c72dcf9b1ada306348ce1f WHIRLPOOL e6bfdde3def0eea89e4bbfdf62471ba87bee9e9e9ba52e6e15ee6ff6335dada1dea0b63abdb21fba464c7298bfc1200848815a335116bc92e9e87a136ff4b223
diff --git a/x11-terms/kterm/files/6.2.0-underline.patch b/x11-terms/kterm/files/6.2.0-underline.patch
new file mode 100644
index 00000000000..5324c4cfa3f
--- /dev/null
+++ b/x11-terms/kterm/files/6.2.0-underline.patch
@@ -0,0 +1,22 @@
+--- charproc.c.orig 2005-08-28 17:55:50.000000000 +0900
++++ charproc.c 2005-08-28 18:30:14.000000000 +0900
+@@ -1897,6 +1897,19 @@
+ case 7:
+ term->flags |= INVERSE;
+ break;
++ case 22: /* Reset bold. */
++ /* ECMA-ly incorrect */
++ term->flags &= ~BOLD;
++ break;
++ case 24:
++ term->flags &= ~UNDERLINE;
++ break;
++ case 25: /* Blink, really. */
++ term->flags &= ~BOLD;
++ break;
++ case 27:
++ term->flags &= ~INVERSE;
++ break;
+ #ifdef KTERM_COLOR
+ case 30:
+ case 31:
diff --git a/x11-terms/kterm/files/kterm-6.2.0-Xaw3d.patch b/x11-terms/kterm/files/kterm-6.2.0-Xaw3d.patch
new file mode 100644
index 00000000000..cda8856a8cf
--- /dev/null
+++ b/x11-terms/kterm/files/kterm-6.2.0-Xaw3d.patch
@@ -0,0 +1,25 @@
+diff -Naur kterm-6.2.0/Imakefile kterm-6.2.0-Xaw3d/Imakefile
+--- kterm-6.2.0/Imakefile 2003-12-13 15:35:05.000000000 +0900
++++ kterm-6.2.0-Xaw3d/Imakefile 2003-12-13 23:10:24.000000000 +0900
+@@ -23,6 +23,10 @@
+ PUCCPTYDDEF = -DPUCC_PTYD /* does not need to be setuid */
+ PTYLIB = -lpucc
+ #endif
++#ifdef KTERM_XAW3D
++ XAWLIB = -lXaw3d
++ XAW6LIB = -lXaw3d
++#endif
+
+ OSMAJORVERSION = OSMajorVersion
+ OSMINORVERSION = OSMinorVersion
+diff -Naur kterm-6.2.0/kterm.h kterm-6.2.0-Xaw3d/kterm.h
+--- kterm-6.2.0/kterm.h 2003-12-13 15:35:05.000000000 +0900
++++ kterm-6.2.0-Xaw3d/kterm.h 2003-12-13 15:35:55.000000000 +0900
+@@ -36,6 +36,6 @@
+ #define KTERM_KINPUT2 /* Kinput2 protocol */
+ #define KTERM_COLOR /* color sequence */
+ #define KTERM_NOTEK /* disables Tektronix emulation */
+-#undef KTERM_XAW3D /* Xaw3d -DARROW_SCROLLBAR support */
++#define KTERM_XAW3D /* Xaw3d -DARROW_SCROLLBAR support */
+
+ #endif /* !_KTERM_H_ */
diff --git a/x11-terms/kterm/files/kterm-6.2.0-gentoo.patch b/x11-terms/kterm/files/kterm-6.2.0-gentoo.patch
new file mode 100644
index 00000000000..f05a0b13537
--- /dev/null
+++ b/x11-terms/kterm/files/kterm-6.2.0-gentoo.patch
@@ -0,0 +1,51 @@
+diff -Naur kterm-6.2.0/main.c kterm-6.2.0-gentoo/main.c
+--- kterm-6.2.0/main.c 1996-07-12 14:01:38.000000000 +0900
++++ kterm-6.2.0-gentoo/main.c 2002-05-21 08:37:31.000000000 +0900
+@@ -75,9 +75,12 @@
+ #include <X11/Xos.h>
+ #include <X11/cursorfont.h>
+ #include <X11/Xaw/SimpleMenu.h>
++/*
+ #ifndef NO_XPOLL_H
+ #include <X11/Xpoll.h>
+ #endif
++*/
++#include <termios.h>
+ #include <X11/Xlocale.h>
+ #include <pwd.h>
+ #include <ctype.h>
+@@ -283,7 +286,7 @@
+ #include <lastlog.h>
+ # endif
+ #endif
+-#include <sys/param.h> /* for NOFILE */
++//#include <sys/param.h> /* for NOFILE */
+
+ #ifdef PUCC_PTYD
+ #include <local/openpty.h>
+diff -Naur kterm-6.2.0/screen.c kterm-6.2.0-gentoo/screen.c
+--- kterm-6.2.0/screen.c 1996-06-23 17:00:26.000000000 +0900
++++ kterm-6.2.0-gentoo/screen.c 2002-05-21 08:30:55.000000000 +0900
+@@ -46,7 +46,8 @@
+ #include <sys/ptem.h>
+ #endif
+
+-extern Char *calloc(), *malloc(), *realloc();
++//extern Char *calloc(), *malloc(), *realloc();
++extern void *calloc(), *malloc(), *realloc();
+ extern void free();
+
+ ScrnBuf Allocate (nrow, ncol, addr)
+diff -Naur kterm-6.2.0/scrollbar.c kterm-6.2.0-gentoo/scrollbar.c
+--- kterm-6.2.0/scrollbar.c 1996-07-12 14:01:39.000000000 +0900
++++ kterm-6.2.0-gentoo/scrollbar.c 2002-05-21 08:30:39.000000000 +0900
+@@ -324,7 +324,8 @@
+ register TScreen *screen = &xw->screen;
+ register int border = 2 * screen->border;
+ register int i;
+- Char *realloc(), *calloc();
++// Char *realloc(), *calloc();
++ void *realloc(), *calloc();
+
+ if(screen->scrollbar)
+ return;
diff --git a/x11-terms/kterm/files/kterm-6.2.0-openpty.patch b/x11-terms/kterm/files/kterm-6.2.0-openpty.patch
new file mode 100644
index 00000000000..ee8bc1814ae
--- /dev/null
+++ b/x11-terms/kterm/files/kterm-6.2.0-openpty.patch
@@ -0,0 +1,59 @@
+diff -ru kterm-orig/Imakefile kterm-6.2.0/Imakefile
+--- kterm-orig/Imakefile 2004-10-12 01:23:25.000000000 +0200
++++ kterm-6.2.0/Imakefile 2004-10-12 01:37:59.100764752 +0200
+@@ -23,6 +23,11 @@
+ PUCCPTYDDEF = -DPUCC_PTYD /* does not need to be setuid */
+ PTYLIB = -lpucc
+ #endif
++#ifdef LinuxArchitecture
++ PTYLIB = -lutil
++#undef InstallXtermSetUID
++#define InstallXtermSetUID 0
++#endif
+
+ OSMAJORVERSION = OSMajorVersion
+ OSMINORVERSION = OSMinorVersion
+diff -ru kterm-orig/button.c kterm-6.2.0/button.c
+--- kterm-orig/button.c 1996-07-02 07:01:46.000000000 +0200
++++ kterm-6.2.0/button.c 2004-10-12 01:29:59.420687208 +0200
+@@ -41,8 +41,6 @@
+ #include "error.h"
+ #include "menu.h"
+
+-extern char *malloc();
+-
+ extern void DoSecureKeyboard();
+
+ #define KeyState(x) (((x) & (ShiftMask|ControlMask)) + (((x) & Mod1Mask) ? 2 : 0))
+diff -ru kterm-orig/charproc.c kterm-6.2.0/charproc.c
+--- kterm-orig/charproc.c 2004-10-12 01:23:25.000000000 +0200
++++ kterm-6.2.0/charproc.c 2004-10-12 01:30:29.640093160 +0200
+@@ -102,8 +102,6 @@
+ extern XtAppContext app_con;
+ extern Widget toplevel;
+ extern void exit();
+-extern char *malloc();
+-extern char *realloc();
+ extern fd_set Select_mask;
+ extern fd_set X_mask;
+ extern fd_set pty_mask;
+diff -ru kterm-orig/main.c kterm-6.2.0/main.c
+--- kterm-orig/main.c 2004-10-12 01:23:25.000000000 +0200
++++ kterm-6.2.0/main.c 2004-10-12 01:32:56.697737000 +0200
+@@ -143,6 +143,7 @@
+ #define HAS_UTMP_UT_HOST
+ #define LASTLOG
+ #define WTMP
++#include <pty.h>
+ #endif
+
+ #include <sys/ioctl.h>
+@@ -1871,7 +1872,7 @@
+ get_pty (pty)
+ int *pty;
+ {
+-#ifdef __osf__
++#if defined(__osf__) || defined(linux)
+ int tty;
+ return (openpty(pty, &tty, ttydev, NULL, NULL));
+ #endif
diff --git a/x11-terms/kterm/files/kterm-ad-gentoo.diff b/x11-terms/kterm/files/kterm-ad-gentoo.diff
new file mode 100644
index 00000000000..a502bac0eb7
--- /dev/null
+++ b/x11-terms/kterm/files/kterm-ad-gentoo.diff
@@ -0,0 +1,21 @@
+--- KTerm.ad.orig 2004-01-07 06:25:15.000000000 +0900
++++ KTerm.ad 2004-01-07 06:27:43.550017672 +0900
+@@ -125,3 +125,18 @@
+
+ *VT100*translations: #override Shift<Key>space: \
+ begin-conversion(_JAPANESE_CONVERSION)
++
++! default values added by portage
++*VT100*kanjiMode: euc
++*inputMethod: kinput2
++!*openIm: true
++! To use wallpaper, uncomment and set it to your favorite image
++!*wallPaper: /path/to/filename.xpm
++
++! To enable wheel mouse
++KTerm*VT100.Translations: #override\n\
++ <KeyPress>Prior:scroll-back(1,page)\n\
++ <KeyPress>Next:scroll-forw(1,page)\n\
++ Shift<Key>space:begin-conversion(_JAPANESE_CONVERSION)\n\
++ <Btn4Down>:scroll-back(1,halfpage)\n\
++ <Btn5Down>:scroll-forw(1,halfpage)\n
diff --git a/x11-terms/kterm/kterm-6.2.0-r5.ebuild b/x11-terms/kterm/kterm-6.2.0-r5.ebuild
new file mode 100644
index 00000000000..4dc36fd1c6f
--- /dev/null
+++ b/x11-terms/kterm/kterm-6.2.0-r5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Japanese Kanji X Terminal"
+SRC_URI="ftp://ftp.x.org/contrib/applications/${P}.tar.gz
+ http://www.asahi-net.or.jp/~hc3j-tkg/kterm/${P}-wpi.patch.gz
+ http://www.st.rim.or.jp/~hanataka/${P}.ext02.patch.gz"
+# until someone who reads japanese can find a better place
+HOMEPAGE="http://www.asahi-net.or.jp/~hc3j-tkg/kterm/"
+
+LICENSE="MIT HPND XC"
+SLOT="0"
+KEYWORDS="-alpha amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="Xaw3d"
+
+RDEPEND="app-text/rman
+ sys-libs/ncurses
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libxkbfile
+ x11-libs/libXaw
+ x11-libs/libXp
+ Xaw3d? ( x11-libs/libXaw3d )"
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_prepare(){
+ epatch "${WORKDIR}"/${P}-wpi.patch # wallpaper patch
+ epatch "${WORKDIR}"/${P}.ext02.patch # JIS 0213 support
+ epatch "${FILESDIR}"/${P}-openpty.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-ad-gentoo.diff
+ epatch "${FILESDIR}"/${PV}-underline.patch
+
+ if use Xaw3d ; then
+ epatch "${FILESDIR}"/kterm-6.2.0-Xaw3d.patch
+ fi
+}
+
+src_compile(){
+ PKG_CONFIG=$(tc-getPKG_CONFIG)
+ xmkmf -a || die
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS} $($PKG_CONFIG --libs ncurses)" \
+ XAPPLOADDIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_install(){
+ emake DESTDIR="${D}" BINDIR="${EPREFIX}"/usr/bin XAPPLOADDIR="${EPREFIX}"/usr/share/X11/app-defaults install
+
+ # install man pages
+ newman kterm.man kterm.1
+ insinto /usr/share/man/ja/man1
+ iconv -f ISO-2022-JP -t EUC-JP kterm.jman > kterm.ja.1
+ newins kterm.ja.1 kterm.1
+
+ # Remove link to avoid collision
+ rm -f "${ED}"/usr/lib/X11/app-defaults
+
+ dodoc README.kt
+}
+
+pkg_postinst() {
+ elog
+ elog "KTerm wallpaper support is enabled."
+ elog "In order to use this feature,"
+ elog "you need specify favourite xpm file with -wp option"
+ elog
+ elog "\t% kterm -wp filename.xpm"
+ elog
+ elog "or set it with X resource"
+ elog
+ elog "\tKTerm*wallPaper: /path/to/filename.xpm"
+ elog
+}
diff --git a/x11-terms/kterm/metadata.xml b/x11-terms/kterm/metadata.xml
new file mode 100644
index 00000000000..2d5852c16c6
--- /dev/null
+++ b/x11-terms/kterm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>