summaryrefslogtreecommitdiff
path: root/x11-terms
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-26 19:36:13 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-26 19:36:33 +0100
commit92cbb16cde6a3ed26a571d001fa2772bdf326194 (patch)
treeab9150ee58af248698b62750eaa33f6336364b14 /x11-terms
parentdcfd2fffaa63af65a4aa2c2973c877d055250554 (diff)
downloadgentoo-92cbb16cde6a3ed26a571d001fa2772bdf326194.tar.gz
gentoo-92cbb16cde6a3ed26a571d001fa2772bdf326194.tar.xz
x11-terms/yeahconsole: EAPI=6 (bug #648884).
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild b/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild
index 08c40f4f0d4..5cbb5121559 100644
--- a/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild
+++ b/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
-
-inherit eutils toolchain-funcs
+EAPI=6
+inherit toolchain-funcs
DESCRIPTION="yeahconsole turns an xterm or rxvt-unicode into a game-like console"
HOMEPAGE="http://phrat.de/yeahtools.html"
@@ -12,24 +11,25 @@ SRC_URI="http://phrat.de/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 hppa x86"
-
-IUSE=""
-RDEPEND="x11-libs/libX11"
-DEPEND="${RDEPEND}
- x11-proto/xproto"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-make.patch
-}
+RDEPEND="
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xproto
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-make.patch
+)
src_compile() {
tc-export CC
- emake || die "make failed"
+ emake
}
src_install() {
dodir /usr/bin
- emake PREFIX="${D}"/usr install || die "emake install failed"
+ emake PREFIX="${D}"/usr install
dodoc README
}