summaryrefslogtreecommitdiff
path: root/x11-themes/gnome-colors-common
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/gnome-colors-common
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/gnome-colors-common')
-rw-r--r--x11-themes/gnome-colors-common/Manifest2
-rw-r--r--x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild58
-rw-r--r--x11-themes/gnome-colors-common/metadata.xml9
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-themes/gnome-colors-common/Manifest b/x11-themes/gnome-colors-common/Manifest
new file mode 100644
index 00000000000..bcd5fd1ee7c
--- /dev/null
+++ b/x11-themes/gnome-colors-common/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-colors-5.5.1.tar.gz 4919865 SHA256 1e91d845a753eb38671e7614a786f852ab858a12983111e780da4a47c9debe58
+DIST tango-gentoo-v1.1.tar.gz 29322 SHA256 518efa4257c8e689488399db23397a89f4dcd5990ce537ef6215860ad5606eb0 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045 WHIRLPOOL 9e1635a505ea48f4fe8bdb3b8b3b43cfb9cf99e3204194c51361b198886e719921cfacbc15f9f6407aa7d0c4af178e24c74b998fc370fa2329040e5be1baf153
diff --git a/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild b/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild
new file mode 100644
index 00000000000..86840c71065
--- /dev/null
+++ b/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit gnome2-utils
+
+DESCRIPTION="Colorized icons shared between all gnome-colors iconsets"
+HOMEPAGE="http://code.google.com/p/gnome-colors/"
+
+SRC_URI="http://gnome-colors.googlecode.com/files/gnome-colors-${PV}.tar.gz
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+
+LICENSE="GPL-2
+ branding? ( CC-Sampling-Plus-1.0 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+branding"
+
+RDEPEND="x11-themes/gnome-icon-theme"
+DEPEND=""
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 ; do
+ cp tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ gnome-colors-common/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ cp tango-gentoo-v1.1/scalable/gentoo.svg \
+ gnome-colors-common/scalable/places/start-here.svg \
+ || die "Copying scalable logo failed"
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ dodir /usr/share/icons
+ insinto /usr/share/icons
+ doins -r "${WORKDIR}/${PN}" || die "Installing icons failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/x11-themes/gnome-colors-common/metadata.xml b/x11-themes/gnome-colors-common/metadata.xml
new file mode 100644
index 00000000000..c421ccfa930
--- /dev/null
+++ b/x11-themes/gnome-colors-common/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+</pkgmetadata> \ No newline at end of file