summaryrefslogtreecommitdiff
path: root/x11-themes/greybird
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/greybird
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/greybird')
-rw-r--r--x11-themes/greybird/Manifest3
-rw-r--r--x11-themes/greybird/greybird-1.2.2.ebuild41
-rw-r--r--x11-themes/greybird/greybird-1.3.4.ebuild42
-rw-r--r--x11-themes/greybird/greybird-1.5.3.ebuild42
-rw-r--r--x11-themes/greybird/metadata.xml12
5 files changed, 140 insertions, 0 deletions
diff --git a/x11-themes/greybird/Manifest b/x11-themes/greybird/Manifest
new file mode 100644
index 00000000000..fa181d27235
--- /dev/null
+++ b/x11-themes/greybird/Manifest
@@ -0,0 +1,3 @@
+DIST greybird-1.2.2.tar.gz 112022 SHA256 b54c73da705dc5607e439435b99262783be562882efe43957c6cf012394496a0 SHA512 0384647c51e6b473f104c10d5418f8d1e465190dcbfdaebc9946f47cab77e90d7c81555cf94c47298a053e150c6b92adfd0d5c84f20f2b5f2ebcc0e12cdb444e WHIRLPOOL 2b3dd85461408a539dba7881d73a088dfdcd4bbf1d74142e359e6429da8f837f9dd5292efedbd4b7c7a646e61bced0aae923bdbc29049714b5ad177a8bdd62ae
+DIST greybird-1.3.4.tar.gz 116901 SHA256 d4c3ea3445d191f639fd045feea43f7139375da94478c3789f0a319f24c3ff4a SHA512 78bb9372d9c05c7c83ae130a3559f7b1f413bb0519d5f626d477bef917ca35892c7b0235872a084720fdba5aa5b381401fb36f7fa11dea00bc0986c76670c286 WHIRLPOOL f40381dcbc9df3a15883df83f2d2480d4add48e45d0d77dddf9781fb4c4cc928011c845892b02e7be070badb6e3c89dc69b2f7701d4911b6678c3976fea92b8c
+DIST greybird-1.5.3.tar.gz 118732 SHA256 856f092ebd199a2a28346938a3dfe62613135ad886c25bbaeebd3a917de4c962 SHA512 1010019b1341cf1c0d48d15d0bc371bbe62e3b6d4aa5d8feb6998093487f465c7dbe42133753a6ca74a01e351ce7b15fcc14c4e194a97034e2e4c171885accae WHIRLPOOL c7b724e11a7f2a4098b83744bba06e93f7c04fb5725b25a6d373f0b11438df9cbdd7db07fbe93e43f173b4ed6de2221eef0702622a3601a0f72c049c2bc54c8c
diff --git a/x11-themes/greybird/greybird-1.2.2.ebuild b/x11-themes/greybird/greybird-1.2.2.ebuild
new file mode 100644
index 00000000000..777236e5e1f
--- /dev/null
+++ b/x11-themes/greybird/greybird-1.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN/g/G}
+
+DESCRIPTION="The default theme from Xubuntu"
+HOMEPAGE="http://shimmerproject.org/project/greybird/ http://github.com/shimmerproject/Greybird"
+SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-NC-SA-3.0 || ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="ayatana gnome"
+
+RDEPEND=">=x11-themes/gtk-engines-murrine-0.90"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+src_unpack() {
+ unpack ${A}
+ mv ${MY_PN}-* "${S}" || die
+}
+
+src_install() {
+ dodoc README
+ rm -f README LICENSE*
+
+ insinto /usr/share/themes/${MY_PN}_compact/xfwm4
+ doins xfwm4_compact/*
+ rm -rf xfwm4_compact
+
+ use ayatana || rm -rf unity
+ use gnome || rm -rf metacity-1
+
+ insinto /usr/share/themes/${MY_PN}
+ doins -r *
+}
diff --git a/x11-themes/greybird/greybird-1.3.4.ebuild b/x11-themes/greybird/greybird-1.3.4.ebuild
new file mode 100644
index 00000000000..39b30556a70
--- /dev/null
+++ b/x11-themes/greybird/greybird-1.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN/g/G}
+
+DESCRIPTION="The default theme from Xubuntu"
+HOMEPAGE="http://shimmerproject.org/project/greybird/ http://github.com/shimmerproject/Greybird"
+SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# README says "dual-licensed as GPLv2 or later and CC-BY-SA 3.0 or later"
+LICENSE="CC-BY-SA-3.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ayatana gnome"
+
+RDEPEND=">=x11-themes/gtk-engines-murrine-0.90"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+src_unpack() {
+ unpack ${A}
+ mv ${MY_PN}-* "${S}" || die
+}
+
+src_install() {
+ dodoc README
+ rm -f README LICENSE*
+
+ insinto /usr/share/themes/${MY_PN}_compact/xfwm4
+ doins xfwm4_compact/*
+ rm -rf xfwm4_compact
+
+ use ayatana || rm -rf unity
+ use gnome || rm -rf metacity-1
+
+ insinto /usr/share/themes/${MY_PN}
+ doins -r *
+}
diff --git a/x11-themes/greybird/greybird-1.5.3.ebuild b/x11-themes/greybird/greybird-1.5.3.ebuild
new file mode 100644
index 00000000000..3ef09dcdc14
--- /dev/null
+++ b/x11-themes/greybird/greybird-1.5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN/g/G}
+
+DESCRIPTION="The default theme from Xubuntu"
+HOMEPAGE="http://shimmerproject.org/project/greybird/ http://github.com/shimmerproject/Greybird"
+SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# README says "dual-licensed as GPLv2 or later and CC-BY-SA 3.0 or later"
+LICENSE="CC-BY-SA-3.0 GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="ayatana gnome"
+
+RDEPEND=">=x11-themes/gtk-engines-murrine-0.90"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+src_unpack() {
+ unpack ${A}
+ mv ${MY_PN}-* "${S}" || die
+}
+
+src_install() {
+ dodoc README
+ rm -f README LICENSE*
+
+ insinto /usr/share/themes/${MY_PN}_compact/xfwm4
+ doins xfwm4_compact/*
+ rm -rf xfwm4_compact
+
+ use ayatana || rm -rf unity
+ use gnome || rm -rf metacity-1
+
+ insinto /usr/share/themes/${MY_PN}
+ doins -r *
+}
diff --git a/x11-themes/greybird/metadata.xml b/x11-themes/greybird/metadata.xml
new file mode 100644
index 00000000000..324478bd550
--- /dev/null
+++ b/x11-themes/greybird/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <herd>ayatana</herd>
+ <maintainer>
+ <email>ayatana-bugs@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">shimmerproject/Greybird</remote-id>
+ </upstream>
+</pkgmetadata>