summaryrefslogtreecommitdiff
path: root/x11-themes/redhat-artwork
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/redhat-artwork
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/redhat-artwork')
-rw-r--r--x11-themes/redhat-artwork/Manifest1
-rw-r--r--x11-themes/redhat-artwork/metadata.xml13
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-5.0.8-r4.ebuild144
3 files changed, 158 insertions, 0 deletions
diff --git a/x11-themes/redhat-artwork/Manifest b/x11-themes/redhat-artwork/Manifest
new file mode 100644
index 00000000000..c4504041857
--- /dev/null
+++ b/x11-themes/redhat-artwork/Manifest
@@ -0,0 +1 @@
+DIST redhat-artwork-5.0.8-4.fc7.src.rpm 8298864 SHA256 ca4372b0174999d249400150365c48bcc2e2f8cd8564ce7b5cf8d8bab1dae268 SHA512 e063a281fd561708e560d91b9eb276b0caa80dd6060513240a0a31b6089f3c97fb9959091d719dd6e84b47838408c991a9645be9fc081709027de4d2f2c95a51 WHIRLPOOL 080a47c1091bd98ff09c4b37069905d177c5d391c2f73d298c330b16e53b75232ecba88ae089ed7c5e54b2e85862de796b5259e3cadb50dfde61b8f0fe171db3
diff --git a/x11-themes/redhat-artwork/metadata.xml b/x11-themes/redhat-artwork/metadata.xml
new file mode 100644
index 00000000000..f7a01680228
--- /dev/null
+++ b/x11-themes/redhat-artwork/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+<use>
+<flag name='audacious'>Install <pkg>media-sound/audacious</pkg> theme</flag>
+<flag name='cursors'>Install Bluecurve cursors</flag>
+<flag name='gdm'>Install Bluecurve <pkg>gnome-base/gdm</pkg> theme</flag>
+<flag name='icons'>Install Bluecurve icons</flag>
+<flag name='kdm'>Install Bluecurve <pkg>kde-base/kdm</pkg> theme</flag>
+<flag name='nautilus'>Install Bluecurve <pkg>gnome-base/nautilus</pkg> icons</flag>
+</use>
+</pkgmetadata>
diff --git a/x11-themes/redhat-artwork/redhat-artwork-5.0.8-r4.ebuild b/x11-themes/redhat-artwork/redhat-artwork-5.0.8-r4.ebuild
new file mode 100644
index 00000000000..05f32d16f95
--- /dev/null
+++ b/x11-themes/redhat-artwork/redhat-artwork-5.0.8-r4.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils rpm
+
+MY_R=${PR/r/}
+DESCRIPTION="RedHat's Bluecurve theme for GTK2, KDE, GDM, Metacity and Nautilus"
+HOMEPAGE="http://www.redhat.com"
+SRC_URI="mirror://gentoo/${P}-${MY_R}.fc7.src.rpm"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ppc sparc x86"
+IUSE="audacious cursors gdm icons kdm nautilus"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ media-gfx/icon-slicer
+ virtual/pkgconfig
+"
+
+RESTRICT="test"
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/redhat-artwork-5.0.5-add-dirs-to-bluecurve-theme-index.patch
+ epatch "${WORKDIR}"/redhat-artwork-5.0.8-echo.patch
+
+ # dies if LANG has UTF-8
+ export LANG=C
+ export LC_ALL=C
+
+ rm -f configure
+ sed -i \
+ -e 's|.*MCOPIDL.*||' \
+ -e 's|.*ARTSCCONFIG.*||' \
+ acinclude.m4 || die
+
+ sed -i \
+ -e 's|AC_PATH_KDE||' \
+ -e 's|KDE_CHECK_FINAL||' \
+ -e 's|KDE_SET_PREFIX||' \
+ -e 's|art/kde/Makefile||' \
+ -e 's|art/kde/kwin/Bluecurve/Makefile||' \
+ -e 's|art/kde/kwin/Makefile||' \
+ -e 's|dnl KDE_USE_QT||' \
+ configure.in || die
+
+ sed -i \
+ -e 's|kde||' \
+ -e 's|qt||' \
+ art/Makefile.am || die
+
+ sed -i \
+ -e 's| $(datadir)| $(DESTDIR)$(datadir)|' \
+ art/cursor/Bluecurve/Makefile.am \
+ art/cursor/Bluecurve-inverse/Makefile.am \
+ art/cursor/LBluecurve/Makefile.am \
+ art/cursor/LBluecurve-inverse/Makefile.am \
+ art/icon/Makefile.am \
+ art/icon/Bluecurve/sheets/Makefile.am || die
+
+ eautoreconf
+
+ intltoolize --force || die
+
+ sed -i -e 's|GtkStyle|4|' art/qt/Bluecurve/bluecurve.cpp || die
+}
+
+src_compile() {
+ emake QTDIR="${QTDIR}" styledir="${QTDIR}/plugins/styles"
+}
+
+src_install () {
+ # dies if LANG has UTF-8
+ export LANG=C
+ export LC_ALL=C
+
+ emake \
+ QTDIR="${QTDIR}" \
+ styledir="${QTDIR}/plugins/styles" \
+ DESTDIR="${D}" \
+ install
+
+ # yank redhat logos (registered trademarks, etc)
+ rm -f "${D}/usr/share/gdm/themes/Bluecurve/rh_logo-header.png"
+ rm -f "${D}/usr/share/gdm/themes/Bluecurve/screenshot.png"
+
+ cd "${D}/usr/share/gdm/themes/Bluecurve/" || die
+
+ # replace redhat logo with gnome logo from happygnome theme, use .svg if >=gnome-base/gdm-2.14 installed
+ if has_version gnome-base/gdm >=2.14; then
+ sed -i \
+ -e 's|<normal file="rh_logo-header.png"/>|<normal file="/usr/share/gdm/themes/happygnome/gnome-logo.svg"/>|' \
+ -e 's|<pos x="3%" y="5%" width="398" height="128" anchor="nw"/>|<pos x="3%" y="3%"/>|' Bluecurve.xml \
+ || die
+ else
+ sed -i \
+ -e 's|<normal file="rh_logo-header.png"/>|<normal file="/usr/share/gdm/themes/happygnome/gnome-logo.png"/>|' \
+ -e 's|<pos x="3%" y="5%" width="398" height="128" anchor="nw"/>|<pos x="3%" y="3%"/>|' Bluecurve.xml \
+ || die
+ fi
+
+ # Bluecurve GDM screenshot has redhat logo
+ # Theme copyright notice left intact... do not modify it
+ sed -i -e 's|Screenshot=|#Screenshot=|' GdmGreeterTheme.desktop || die
+
+ X11_IMPLEM="xorg-x11"
+
+ for x in Bluecurve Bluecurve-inverse; do
+ dodir /usr/share/cursors/${X11_IMPLEM}/${x}
+ mv "${D}"/usr/share/icons/${x}/cursors "${D}"/usr/share/cursors/${X11_IMPLEM}/${x}
+ dosym /usr/share/cursors/${X11_IMPLEM}/${x}/cursors /usr/share/icons/${x}/cursors
+ done
+
+ # remove audacious skin if unneeded
+ if ! use audacious; then
+ rm -r "${D}"/usr/share/xmms || die
+ else
+ mv "${D}"/usr/share/xmms "${D}"/usr/share/audacious || die
+ fi
+
+ cd "${S}"
+ dodoc AUTHORS NEWS README ChangeLog
+
+ ###
+ # Some extra features - allows redhat-artwork to be very light:
+ ###
+ if ! use gdm; then rm -r "${D}"/usr/share/gdm || die; fi
+ if ! use kdm; then rm -r "${D}"/usr/share/apps/kdm || die; fi
+ if ! use cursors; then rm -r "${D}"/usr/share/cursors || die; fi
+ if ! use icons; then
+ rm -r "${D}"/usr/share/icons || die
+ rm -r "${D}"/usr/share/pixmaps/*.png || die
+ fi
+ if ! use nautilus; then rm -r "${D}"/usr/share/pixmaps/nautilus || die; fi
+}