summaryrefslogtreecommitdiff
path: root/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild')
-rw-r--r--x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild b/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
new file mode 100644
index 00000000000..31ab1600699
--- /dev/null
+++ b/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnome2-utils
+
+DESCRIPTION="a derivative of the standard Tango theme, using a more orange approach"
+HOMEPAGE="http://packages.ubuntu.com/gutsy/x11/tangerine-icon-theme"
+SRC_URI="mirror://ubuntu/pool/universe/t/${PN}/${PN}_${PV}.tar.gz
+ http://www.gentoo.org/images/gentoo-logo.svg"
+
+LICENSE="CC-BY-SA-2.5 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="minimal"
+
+RESTRICT="binchecks strip"
+
+RDEPEND="!minimal? ( || ( x11-themes/gnome-icon-theme kde-apps/oxygen-icons ) )"
+DEPEND="dev-util/intltool
+ >=gnome-base/librsvg-2.34
+ sys-devel/gettext
+ >=x11-misc/icon-naming-utils-0.8.90"
+
+DOCS="AUTHORS README"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:lib/icon-naming-utils/icon:libexec/icon:' \
+ Makefile || die
+
+ cp "${DISTDIR}"/gentoo-logo.svg scalable/places/start-here.svg || die
+
+ local res
+ for res in 16 22 32; do
+ rsvg-convert -w ${res} -h ${res} scalable/places/start-here.svg \
+ > ${res}x${res}/places/start-here.png || die
+ done
+}
+
+src_compile() {
+ emake index.theme
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }