summaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-07-31 04:19:57 +0300
committerMart Raudsepp <leio@gentoo.org>2017-07-31 06:39:54 +0300
commita6dff57628e5d106b6d2228cfadcbab3bde8368d (patch)
tree27541b9050da9c326b9c870f7f37e5e73d270b74 /x11-themes
parentbee3a8d385667f50753d725e6fa94e45a0dec7f7 (diff)
downloadgentoo-a6dff57628e5d106b6d2228cfadcbab3bde8368d.tar.gz
gentoo-a6dff57628e5d106b6d2228cfadcbab3bde8368d.tar.xz
x11-themes/adwaita-icon-theme: bump to 3.24.0, add missing gtk+ build depend
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/adwaita-icon-theme/Manifest1
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.24.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/Manifest b/x11-themes/adwaita-icon-theme/Manifest
index 547a68933be..04337a3eca2 100644
--- a/x11-themes/adwaita-icon-theme/Manifest
+++ b/x11-themes/adwaita-icon-theme/Manifest
@@ -1,2 +1,3 @@
DIST adwaita-icon-theme-3.22.0.tar.xz 18395856 SHA256 c18bf6e26087d9819a962c77288b291efab25d0419b73d909dd771716a45dcb7 SHA512 33d5eab0a7295069bb3cc8939bebeed0bad8ff72bfe42b0a90e616190ce519e7d7e2b4e9e4c145d04911ea37c205c12ca39972fd00e6ef34271b66a25ff24983 WHIRLPOOL 656556360a4535b4fd29de163f73b03c3f82c568c5d21cc94a6dd35fa478804b39f0c563430edcc5f9f3cdfc920bdf14a0290ecb58314dfd089b62078d873bfb
+DIST adwaita-icon-theme-3.24.0.tar.xz 20717972 SHA256 ccf79ff3bd340254737ce4d28b87f0ccee4b3358cd3cd5cd11dc7b42f41b272a SHA512 d415859bc46deb3dcf5e845af88689c507d6b110d6312af75145d6c46cc277ca2d17ae6a0f506c09ca7d543c5eca47b2506169bb0482ae68f2e3baef70889090 WHIRLPOOL b02598682f512e7a1ed5541464e8b99691d611fd28628be1cd6866b9c59b39fa506dedc53bcedd75ec5ab23358b319a1b48a7e4b662dae374df2e11bd47d96d7
DIST tango-gentoo-v1.1.tar.gz 29322 SHA256 518efa4257c8e689488399db23397a89f4dcd5990ce537ef6215860ad5606eb0 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045 WHIRLPOOL 9e1635a505ea48f4fe8bdb3b8b3b43cfb9cf99e3204194c51361b198886e719921cfacbc15f9f6407aa7d0c4af178e24c74b998fc370fa2329040e5be1baf153
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.24.0.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.24.0.ebuild
new file mode 100644
index 00000000000..c6691b75d24
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.24.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://git.gnome.org/browse/adwaita-icon-theme/"
+
+SRC_URI="${SRC_URI}
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+COMMON_DEPEND="
+ >=x11-themes/hicolor-icon-theme-0.10
+ gnome-base/librsvg:2
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/gtk+:3
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place used in Gentoo
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}