summaryrefslogtreecommitdiff
path: root/x11-wm/xmonad-contrib/xmonad-contrib-0.12.ebuild
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 09:47:54 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 09:48:01 +0000
commit5d95e5c3af215ea30c7758911f638063d1a16aec (patch)
tree7616040f8fc5ac5769d80e1c438456bb14c077be /x11-wm/xmonad-contrib/xmonad-contrib-0.12.ebuild
parent362565644aee9b855b257b26de4234799fe8445d (diff)
downloadgentoo-5d95e5c3af215ea30c7758911f638063d1a16aec.tar.gz
gentoo-5d95e5c3af215ea30c7758911f638063d1a16aec.tar.xz
x11-wm/xmonad-contrib: bump up to 0.12, bug #572018
Reported-by: Mike Limansky Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-wm/xmonad-contrib/xmonad-contrib-0.12.ebuild')
-rw-r--r--x11-wm/xmonad-contrib/xmonad-contrib-0.12.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-wm/xmonad-contrib/xmonad-contrib-0.12.ebuild b/x11-wm/xmonad-contrib/xmonad-contrib-0.12.ebuild
new file mode 100644
index 00000000000..929d3724d14
--- /dev/null
+++ b/x11-wm/xmonad-contrib/xmonad-contrib-0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -testing,use_xft:xft
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Third party extensions for xmonad"
+HOMEPAGE="http://xmonad.org/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+xft"
+
+RDEPEND="dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/mtl-1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/x11-1.6.1:=[profile?] <dev-haskell/x11-1.7:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+ >=x11-wm/xmonad-0.12:=[profile?] <x11-wm/xmonad-0.13:=[profile?]
+ xft? ( >=dev-haskell/x11-xft-0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-testing \
+ $(cabal_flag xft use_xft)
+}