summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2016-06-02 00:31:29 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-03 13:44:13 +0000
commitaa9891be6a04499d27fa0055ff9a17895ea589fc (patch)
tree41bbfa9f39fa6525ef54a319f241704e66e6a5d3 /xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild
parent09fa1e6def10752f5cfb82e3e0707d4a16b29253 (diff)
downloadgentoo-aa9891be6a04499d27fa0055ff9a17895ea589fc.tar.gz
gentoo-aa9891be6a04499d27fa0055ff9a17895ea589fc.tar.xz
xfce-extra/xfce4-whiskermenu-plugin: version bump to 1.5.3
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1540 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild
new file mode 100644
index 00000000000..00713a5aad8
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.5.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin"
+SRC_URI="https://github.com/gottcode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gtk+:2=
+ xfce-base/exo:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:=
+ virtual/libintl:="
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ local i
+ cd po || die
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in *.po ; do
+ einfo "removing ${i%.po} linguas"
+ has ${i%.po} ${LINGUAS} || { rm ${i} || die ; }
+ done
+ fi
+
+ eapply_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}