summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/php/metadata.xml1
-rw-r--r--dev-lang/php/php-5.6.28-r2.ebuild (renamed from dev-lang/php/php-5.6.28-r1.ebuild)4
-rw-r--r--dev-lang/php/php-7.0.14-r1.ebuild (renamed from dev-lang/php/php-7.0.14.ebuild)4
-rw-r--r--dev-lang/php/php-7.1.0-r3.ebuild (renamed from dev-lang/php/php-7.1.0-r2.ebuild)4
4 files changed, 10 insertions, 3 deletions
diff --git a/dev-lang/php/metadata.xml b/dev-lang/php/metadata.xml
index 66ecbe7d4a7..64d6bb84b89 100644
--- a/dev-lang/php/metadata.xml
+++ b/dev-lang/php/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="cli">Enable CLI SAPI</flag>
+ <flag name="coverage">Include gcov symbols for test coverage and lcov reports. Only useful for extension developers, and requires GCC.</flag>
<flag name="embed">Enable embed SAPI</flag>
<flag name="enchant">Add supports Enchant spelling library.</flag>
<flag name="fileinfo">Add fileinfo extension support</flag>
diff --git a/dev-lang/php/php-5.6.28-r1.ebuild b/dev-lang/php/php-5.6.28-r2.ebuild
index 735757389db..d0446a119ab 100644
--- a/dev-lang/php/php-5.6.28-r1.ebuild
+++ b/dev-lang/php/php-5.6.28-r2.ebuild
@@ -30,7 +30,7 @@ IUSE="${IUSE}
threads"
IUSE="${IUSE} acl bcmath berkdb bzip2 calendar cdb cjk
- crypt +ctype curl debug
+ coverage crypt +ctype curl debug
enchant exif frontbase +fileinfo +filter firebird
flatfile ftp gd gdbm gmp +hash +iconv imap inifile
intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libressl
@@ -63,6 +63,7 @@ COMMON_DEPEND="
media-libs/libpng:0=
sys-libs/zlib
) )
+ coverage? ( dev-util/lcov )
crypt? ( >=dev-libs/libmcrypt-2.4 )
curl? ( >=net-misc/curl-7.10.5 )
enchant? ( app-text/enchant )
@@ -301,6 +302,7 @@ src_configure() {
$(use_enable bcmath bcmath)
$(use_with bzip2 bz2 "${EPREFIX}/usr")
$(use_enable calendar calendar)
+ $(use_enable coverage gcov)
$(use_enable ctype ctype)
$(use_with curl curl "${EPREFIX}/usr")
$(use_enable xml dom)
diff --git a/dev-lang/php/php-7.0.14.ebuild b/dev-lang/php/php-7.0.14-r1.ebuild
index ecc4bce83cd..da9417192ca 100644
--- a/dev-lang/php/php-7.0.14.ebuild
+++ b/dev-lang/php/php-7.0.14-r1.ebuild
@@ -30,7 +30,7 @@ IUSE="${IUSE}
threads"
IUSE="${IUSE} acl bcmath berkdb bzip2 calendar cdb cjk
- crypt +ctype curl debug
+ coverage crypt +ctype curl debug
enchant exif frontbase +fileinfo +filter firebird
flatfile ftp gd gdbm gmp +hash +iconv imap inifile
intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libressl
@@ -63,6 +63,7 @@ COMMON_DEPEND="
media-libs/libpng:0=
sys-libs/zlib
) )
+ coverage? ( dev-util/lcov )
crypt? ( >=dev-libs/libmcrypt-2.4 )
curl? ( >=net-misc/curl-7.10.5 )
enchant? ( app-text/enchant )
@@ -290,6 +291,7 @@ src_configure() {
$(use_enable bcmath bcmath)
$(use_with bzip2 bz2 "${EPREFIX}/usr")
$(use_enable calendar calendar)
+ $(use_enable coverage gcov)
$(use_enable ctype ctype)
$(use_with curl curl "${EPREFIX}/usr")
$(use_enable xml dom)
diff --git a/dev-lang/php/php-7.1.0-r2.ebuild b/dev-lang/php/php-7.1.0-r3.ebuild
index d0298d28bff..2eca60ab054 100644
--- a/dev-lang/php/php-7.1.0-r2.ebuild
+++ b/dev-lang/php/php-7.1.0-r3.ebuild
@@ -30,7 +30,7 @@ IUSE="${IUSE}
threads"
IUSE="${IUSE} acl bcmath berkdb bzip2 calendar cdb cjk
- crypt +ctype curl debug
+ coverage crypt +ctype curl debug
enchant exif frontbase +fileinfo +filter firebird
flatfile ftp gd gdbm gmp +hash +iconv imap inifile
intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libressl
@@ -63,6 +63,7 @@ COMMON_DEPEND="
media-libs/libpng:0=
sys-libs/zlib
) )
+ coverage? ( dev-util/lcov )
crypt? ( >=dev-libs/libmcrypt-2.4 )
curl? ( >=net-misc/curl-7.10.5 )
enchant? ( app-text/enchant )
@@ -264,6 +265,7 @@ src_configure() {
$(use_enable bcmath bcmath)
$(use_with bzip2 bz2 "${EPREFIX}/usr")
$(use_enable calendar calendar)
+ $(use_enable coverage gcov)
$(use_enable ctype ctype)
$(use_with curl curl "${EPREFIX}/usr")
$(use_enable xml dom)