summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/doxygen/doxygen-1.8.10-r1.ebuild5
-rw-r--r--app-doc/doxygen/doxygen-1.8.10.ebuild2
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild10
3 files changed, 8 insertions, 9 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.10-r1.ebuild b/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
index 64bc3e7e633..888691a6b31 100644
--- a/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.10-r1.ebuild
@@ -13,8 +13,7 @@ if [[ ${PV} = *9999* ]]; then
KEYWORDS=""
else
SRC_URI="http://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
- KEYWORDS="~amd64"
- # KEYWORDS="~alpha ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
fi
SRC_URI+=" http://dev.gentoo.org/~xarthisius/distfiles/doxywizard.png"
@@ -23,7 +22,7 @@ HOMEPAGE="http://www.doxygen.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="clang debug doc dot doxysearch latex qt4 sqlite"
+IUSE="clang debug doc dot doxysearch latex qt4 sqlite userland_GNU"
#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
diff --git a/app-doc/doxygen/doxygen-1.8.10.ebuild b/app-doc/doxygen/doxygen-1.8.10.ebuild
index da3f9e69c74..2696cabb0ec 100644
--- a/app-doc/doxygen/doxygen-1.8.10.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.10.ebuild
@@ -23,7 +23,7 @@ HOMEPAGE="http://www.doxygen.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="clang debug doc dot doxysearch qt4 sqlite"
+IUSE="clang debug doc dot doxysearch qt4 sqlite userland_GNU"
#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index 198f278f942..9c6296b23e4 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -15,17 +15,16 @@ else
SRC_URI="http://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz" # switch to github?
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
fi
-SRC_URI+="http://dev.gentoo.org/~xarthisius/distfiles/doxywizard.png"
+SRC_URI+=" http://dev.gentoo.org/~xarthisius/distfiles/doxywizard.png"
DESCRIPTION="Documentation system for most programming languages"
HOMEPAGE="http://www.doxygen.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="clang debug doc dot doxysearch qt4 sqlite"
+IUSE="clang debug doc dot doxysearch latex qt4 sqlite userland_GNU"
#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
-
LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
nl nb pl pt ro ru sl sk sr sv tr uk vi af)
for X in "${LANGS[@]}" ; do
@@ -37,16 +36,18 @@ RDEPEND="app-text/ghostscript-gpl
media-libs/libpng
virtual/libiconv
clang? ( sys-devel/clang )
- doc? ( app-text/texlive[extra] )
dot? (
media-gfx/graphviz
media-libs/freetype
)
doxysearch? ( =dev-libs/xapian-1.2* )
+ latex? ( app-text/texlive[extra] )
qt4? ( dev-qt/qtgui:4 )
sqlite? ( dev-db/sqlite:3 )
"
+REQUIRED_USE="doc? ( latex )"
+
DEPEND="sys-apps/sed
sys-devel/flex
sys-devel/bison
@@ -122,7 +123,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=YES
-DDOC_INSTALL_DIR="share/doc/${P}"
-DLANG_CODES="$(get_langs)"
$(cmake-utils_use clang use_libclang)