summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-conch/twisted-conch-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-conch/twisted-conch-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-conch/twisted-conch-15.2.1.ebuild5
-rw-r--r--dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild5
-rw-r--r--dev-python/twisted-core/twisted-core-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-core/twisted-core-15.1.0.ebuild2
-rw-r--r--dev-python/twisted-core/twisted-core-15.2.1.ebuild2
-rw-r--r--dev-python/twisted-lore/twisted-lore-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-lore/twisted-lore-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-lore/twisted-lore-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-lore/twisted-lore-15.2.1.ebuild5
-rw-r--r--dev-python/twisted-mail/twisted-mail-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-mail/twisted-mail-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-mail/twisted-mail-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-mail/twisted-mail-15.2.1.ebuild5
-rw-r--r--dev-python/twisted-names/twisted-names-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-names/twisted-names-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-names/twisted-names-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-names/twisted-names-15.2.1.ebuild5
-rw-r--r--dev-python/twisted-news/twisted-news-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-news/twisted-news-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-news/twisted-news-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-news/twisted-news-15.2.1.ebuild5
-rw-r--r--dev-python/twisted-pair/twisted-pair-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-pair/twisted-pair-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-pair/twisted-pair-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-pair/twisted-pair-15.2.1.ebuild5
-rw-r--r--dev-python/twisted-runner/twisted-runner-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-runner/twisted-runner-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-runner/twisted-runner-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-runner/twisted-runner-15.2.1.ebuild5
-rw-r--r--dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-web/twisted-web-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-web/twisted-web-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-web/twisted-web-15.2.1.ebuild5
-rw-r--r--dev-python/twisted-words/twisted-words-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-words/twisted-words-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-words/twisted-words-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-words/twisted-words-15.2.1.ebuild5
-rw-r--r--dev-python/twisted/twisted-16.2.0.ebuild12
-rw-r--r--dev-python/twisted/twisted-16.4.1.ebuild12
42 files changed, 132 insertions, 86 deletions
diff --git a/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild b/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
index 0ac3a01acc2..502b455d81b 100644
--- a/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
+++ b/dev-python/twisted-conch/twisted-conch-13.0.0-r1.ebuild
@@ -13,12 +13,13 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]
"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-conch/twisted-conch-13.2.0.ebuild b/dev-python/twisted-conch/twisted-conch-13.2.0.ebuild
index 0ac3a01acc2..502b455d81b 100644
--- a/dev-python/twisted-conch/twisted-conch-13.2.0.ebuild
+++ b/dev-python/twisted-conch/twisted-conch-13.2.0.ebuild
@@ -13,12 +13,13 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]
"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-conch/twisted-conch-15.1.0.ebuild b/dev-python/twisted-conch/twisted-conch-15.1.0.ebuild
index 8b3254d1f3e..4fc34ee84f5 100644
--- a/dev-python/twisted-conch/twisted-conch-15.1.0.ebuild
+++ b/dev-python/twisted-conch/twisted-conch-15.1.0.ebuild
@@ -13,8 +13,9 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-conch/twisted-conch-15.2.1.ebuild b/dev-python/twisted-conch/twisted-conch-15.2.1.ebuild
index 8b3254d1f3e..4fc34ee84f5 100644
--- a/dev-python/twisted-conch/twisted-conch-15.2.1.ebuild
+++ b/dev-python/twisted-conch/twisted-conch-15.2.1.ebuild
@@ -13,8 +13,9 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild b/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
index 9ad0618b6f8..bca82a6434c 100644
--- a/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
+++ b/dev-python/twisted-core/twisted-core-13.0.0-r3.ebuild
@@ -14,12 +14,13 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-f
IUSE="crypt gtk serial"
DEPEND="
- !dev-python/twisted
dev-python/zope-interface[${PYTHON_USEDEP}]
crypt? ( >=dev-python/pyopenssl-0.10[${PYTHON_USEDEP}] )
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-13.2.0.ebuild b/dev-python/twisted-core/twisted-core-13.2.0.ebuild
index a76b78a81c5..f6679b00a8e 100644
--- a/dev-python/twisted-core/twisted-core-13.2.0.ebuild
+++ b/dev-python/twisted-core/twisted-core-13.2.0.ebuild
@@ -14,12 +14,13 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86
IUSE="crypt gtk serial"
DEPEND="
- !dev-python/twisted
>=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
crypt? ( >=dev-python/pyopenssl-0.10[${PYTHON_USEDEP}] )
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-15.1.0.ebuild b/dev-python/twisted-core/twisted-core-15.1.0.ebuild
index 93f7667a2cb..78aad2ec8b1 100644
--- a/dev-python/twisted-core/twisted-core-15.1.0.ebuild
+++ b/dev-python/twisted-core/twisted-core-15.1.0.ebuild
@@ -19,9 +19,9 @@ RDEPEND=">=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
DEPEND="
- !dev-python/twisted
test? ( ${RDEPEND} )
"
+RDEPEND+=" !dev-python/twisted"
PATCHES=(
# Give a load-sensitive test a better chance of succeeding.
diff --git a/dev-python/twisted-core/twisted-core-15.2.1.ebuild b/dev-python/twisted-core/twisted-core-15.2.1.ebuild
index 4e7645a7af9..1ee03465cba 100644
--- a/dev-python/twisted-core/twisted-core-15.2.1.ebuild
+++ b/dev-python/twisted-core/twisted-core-15.2.1.ebuild
@@ -19,9 +19,9 @@ RDEPEND=">=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
gtk? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )"
DEPEND="
- !dev-python/twisted
test? ( ${RDEPEND} )
"
+RDEPEND+=" !dev-python/twisted"
PATCHES=(
# Respect TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE variable.
diff --git a/dev-python/twisted-lore/twisted-lore-13.0.0-r1.ebuild b/dev-python/twisted-lore/twisted-lore-13.0.0-r1.ebuild
index c97c51e227d..7447698b93f 100644
--- a/dev-python/twisted-lore/twisted-lore-13.0.0-r1.ebuild
+++ b/dev-python/twisted-lore/twisted-lore-13.0.0-r1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-web-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-lore/twisted-lore-13.2.0.ebuild b/dev-python/twisted-lore/twisted-lore-13.2.0.ebuild
index c97c51e227d..7447698b93f 100644
--- a/dev-python/twisted-lore/twisted-lore-13.2.0.ebuild
+++ b/dev-python/twisted-lore/twisted-lore-13.2.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-web-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-lore/twisted-lore-15.1.0.ebuild b/dev-python/twisted-lore/twisted-lore-15.1.0.ebuild
index 6fbb0d69d33..13c7d7cd16c 100644
--- a/dev-python/twisted-lore/twisted-lore-15.1.0.ebuild
+++ b/dev-python/twisted-lore/twisted-lore-15.1.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-web-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-lore/twisted-lore-15.2.1.ebuild b/dev-python/twisted-lore/twisted-lore-15.2.1.ebuild
index 6fbb0d69d33..13c7d7cd16c 100644
--- a/dev-python/twisted-lore/twisted-lore-15.2.1.ebuild
+++ b/dev-python/twisted-lore/twisted-lore-15.2.1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-web-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-mail/twisted-mail-13.0.0-r1.ebuild b/dev-python/twisted-mail/twisted-mail-13.0.0-r1.ebuild
index 05503a1ce22..a14dbdc1bcf 100644
--- a/dev-python/twisted-mail/twisted-mail-13.0.0-r1.ebuild
+++ b/dev-python/twisted-mail/twisted-mail-13.0.0-r1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ia64-hp
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-names-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-mail/twisted-mail-13.2.0.ebuild b/dev-python/twisted-mail/twisted-mail-13.2.0.ebuild
index 05503a1ce22..a14dbdc1bcf 100644
--- a/dev-python/twisted-mail/twisted-mail-13.2.0.ebuild
+++ b/dev-python/twisted-mail/twisted-mail-13.2.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ia64-hp
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-names-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-mail/twisted-mail-15.1.0.ebuild b/dev-python/twisted-mail/twisted-mail-15.1.0.ebuild
index cc6eb74e30e..628bce7a20d 100644
--- a/dev-python/twisted-mail/twisted-mail-15.1.0.ebuild
+++ b/dev-python/twisted-mail/twisted-mail-15.1.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~ia64-hpux ~x
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-names-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-mail/twisted-mail-15.2.1.ebuild b/dev-python/twisted-mail/twisted-mail-15.2.1.ebuild
index cc6eb74e30e..628bce7a20d 100644
--- a/dev-python/twisted-mail/twisted-mail-15.2.1.ebuild
+++ b/dev-python/twisted-mail/twisted-mail-15.2.1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~ia64-hpux ~x
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-names-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-names/twisted-names-13.0.0-r1.ebuild b/dev-python/twisted-names/twisted-names-13.0.0-r1.ebuild
index 1ceb3beaf67..013a2061105 100644
--- a/dev-python/twisted-names/twisted-names-13.0.0-r1.ebuild
+++ b/dev-python/twisted-names/twisted-names-13.0.0-r1.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-int
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-names/twisted-names-13.2.0.ebuild b/dev-python/twisted-names/twisted-names-13.2.0.ebuild
index 1ceb3beaf67..013a2061105 100644
--- a/dev-python/twisted-names/twisted-names-13.2.0.ebuild
+++ b/dev-python/twisted-names/twisted-names-13.2.0.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-int
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-names/twisted-names-15.1.0.ebuild b/dev-python/twisted-names/twisted-names-15.1.0.ebuild
index a470c24ac2f..47d676eeebb 100644
--- a/dev-python/twisted-names/twisted-names-15.1.0.ebuild
+++ b/dev-python/twisted-names/twisted-names-15.1.0.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-interix
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-names/twisted-names-15.2.1.ebuild b/dev-python/twisted-names/twisted-names-15.2.1.ebuild
index 78a5c54c941..d48734e80ff 100644
--- a/dev-python/twisted-names/twisted-names-15.2.1.ebuild
+++ b/dev-python/twisted-names/twisted-names-15.2.1.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-i
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-news/twisted-news-13.0.0-r1.ebuild b/dev-python/twisted-news/twisted-news-13.0.0-r1.ebuild
index 4a94def2c48..fd73a4b4eda 100644
--- a/dev-python/twisted-news/twisted-news-13.0.0-r1.ebuild
+++ b/dev-python/twisted-news/twisted-news-13.0.0-r1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-mail-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-news/twisted-news-13.2.0.ebuild b/dev-python/twisted-news/twisted-news-13.2.0.ebuild
index 4a94def2c48..fd73a4b4eda 100644
--- a/dev-python/twisted-news/twisted-news-13.2.0.ebuild
+++ b/dev-python/twisted-news/twisted-news-13.2.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-mail-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-news/twisted-news-15.1.0.ebuild b/dev-python/twisted-news/twisted-news-15.1.0.ebuild
index f2af1d3bcac..64618dbcd9d 100644
--- a/dev-python/twisted-news/twisted-news-15.1.0.ebuild
+++ b/dev-python/twisted-news/twisted-news-15.1.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-mail-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-news/twisted-news-15.2.1.ebuild b/dev-python/twisted-news/twisted-news-15.2.1.ebuild
index f2af1d3bcac..64618dbcd9d 100644
--- a/dev-python/twisted-news/twisted-news-15.2.1.ebuild
+++ b/dev-python/twisted-news/twisted-news-15.2.1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-mail-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-pair/twisted-pair-13.0.0-r1.ebuild b/dev-python/twisted-pair/twisted-pair-13.0.0-r1.ebuild
index 16ebe999ef2..63783000ae3 100644
--- a/dev-python/twisted-pair/twisted-pair-13.0.0-r1.ebuild
+++ b/dev-python/twisted-pair/twisted-pair-13.0.0-r1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="amd64 x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/eunuchs[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-pair/twisted-pair-13.2.0.ebuild b/dev-python/twisted-pair/twisted-pair-13.2.0.ebuild
index 16ebe999ef2..63783000ae3 100644
--- a/dev-python/twisted-pair/twisted-pair-13.2.0.ebuild
+++ b/dev-python/twisted-pair/twisted-pair-13.2.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="amd64 x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/eunuchs[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-pair/twisted-pair-15.1.0.ebuild b/dev-python/twisted-pair/twisted-pair-15.1.0.ebuild
index 43458fe5500..2db54cc3ec8 100644
--- a/dev-python/twisted-pair/twisted-pair-15.1.0.ebuild
+++ b/dev-python/twisted-pair/twisted-pair-15.1.0.ebuild
@@ -13,10 +13,11 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/eunuchs[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
# https://twistedmatrix.com/trac/ticket/7433
PATCHES=( "${FILESDIR}"/14.0.0-tests.patch )
diff --git a/dev-python/twisted-pair/twisted-pair-15.2.1.ebuild b/dev-python/twisted-pair/twisted-pair-15.2.1.ebuild
index 43458fe5500..2db54cc3ec8 100644
--- a/dev-python/twisted-pair/twisted-pair-15.2.1.ebuild
+++ b/dev-python/twisted-pair/twisted-pair-15.2.1.ebuild
@@ -13,10 +13,11 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/eunuchs[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
# https://twistedmatrix.com/trac/ticket/7433
PATCHES=( "${FILESDIR}"/14.0.0-tests.patch )
diff --git a/dev-python/twisted-runner/twisted-runner-13.0.0-r1.ebuild b/dev-python/twisted-runner/twisted-runner-13.0.0-r1.ebuild
index 12bb4241077..df20ba4c811 100644
--- a/dev-python/twisted-runner/twisted-runner-13.0.0-r1.ebuild
+++ b/dev-python/twisted-runner/twisted-runner-13.0.0-r1.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-runner/twisted-runner-13.2.0.ebuild b/dev-python/twisted-runner/twisted-runner-13.2.0.ebuild
index 12bb4241077..df20ba4c811 100644
--- a/dev-python/twisted-runner/twisted-runner-13.2.0.ebuild
+++ b/dev-python/twisted-runner/twisted-runner-13.2.0.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-runner/twisted-runner-15.1.0.ebuild b/dev-python/twisted-runner/twisted-runner-15.1.0.ebuild
index 93d6d33cdbb..3e74dcf6016 100644
--- a/dev-python/twisted-runner/twisted-runner-15.1.0.ebuild
+++ b/dev-python/twisted-runner/twisted-runner-15.1.0.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-runner/twisted-runner-15.2.1.ebuild b/dev-python/twisted-runner/twisted-runner-15.2.1.ebuild
index 93d6d33cdbb..3e74dcf6016 100644
--- a/dev-python/twisted-runner/twisted-runner-15.2.1.ebuild
+++ b/dev-python/twisted-runner/twisted-runner-15.2.1.ebuild
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild b/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
index ab9f1dd662f..e30c41d1d1b 100644
--- a/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
+++ b/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
@@ -13,10 +13,11 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-f
IUSE="soap"
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-web/twisted-web-13.2.0.ebuild b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
index 674840c28e9..ab18fee2d83 100644
--- a/dev-python/twisted-web/twisted-web-13.2.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
@@ -14,11 +14,12 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-f
IUSE="soap"
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-web/twisted-web-15.1.0.ebuild b/dev-python/twisted-web/twisted-web-15.1.0.ebuild
index 4bb97ff3468..3f8a1576bb2 100644
--- a/dev-python/twisted-web/twisted-web-15.1.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-15.1.0.ebuild
@@ -14,11 +14,12 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x8
IUSE="soap"
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-web/twisted-web-15.2.1.ebuild b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
index 5035760681e..29f34756bd7 100644
--- a/dev-python/twisted-web/twisted-web-15.2.1.ebuild
+++ b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
@@ -14,11 +14,12 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-f
IUSE="soap"
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-words/twisted-words-13.0.0-r1.ebuild b/dev-python/twisted-words/twisted-words-13.0.0-r1.ebuild
index d1c4b1fbe99..52f55cd095b 100644
--- a/dev-python/twisted-words/twisted-words-13.0.0-r1.ebuild
+++ b/dev-python/twisted-words/twisted-words-13.0.0-r1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-web-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-words/twisted-words-13.2.0.ebuild b/dev-python/twisted-words/twisted-words-13.2.0.ebuild
index d1c4b1fbe99..52f55cd095b 100644
--- a/dev-python/twisted-words/twisted-words-13.2.0.ebuild
+++ b/dev-python/twisted-words/twisted-words-13.2.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-web-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-words/twisted-words-15.1.0.ebuild b/dev-python/twisted-words/twisted-words-15.1.0.ebuild
index cfd88a71663..3bdb7e5fdb5 100644
--- a/dev-python/twisted-words/twisted-words-15.1.0.ebuild
+++ b/dev-python/twisted-words/twisted-words-15.1.0.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-web-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted-words/twisted-words-15.2.1.ebuild b/dev-python/twisted-words/twisted-words-15.2.1.ebuild
index cfd88a71663..3bdb7e5fdb5 100644
--- a/dev-python/twisted-words/twisted-words-15.2.1.ebuild
+++ b/dev-python/twisted-words/twisted-words-15.2.1.ebuild
@@ -13,7 +13,8 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
IUSE=""
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
=dev-python/twisted-web-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
diff --git a/dev-python/twisted/twisted-16.2.0.ebuild b/dev-python/twisted/twisted-16.2.0.ebuild
index 7f47bfc43ef..88b2a5bda8b 100644
--- a/dev-python/twisted/twisted-16.2.0.ebuild
+++ b/dev-python/twisted/twisted-16.2.0.ebuild
@@ -31,14 +31,18 @@ RDEPEND=">=dev-python/zope-interface-3.6.0[${PYTHON_USEDEP}]
)
serial? ( dev-python/pyserial[${PYTHON_USEDEP}] )
soap? ( $(python_gen_cond_dep 'dev-python/soappy[${PYTHON_USEDEP}]' python2_7) )
-"
-DEPEND="
- !dev-python/twisted-core
!dev-python/twisted-conch
+ !dev-python/twisted-core
+ !dev-python/twisted-lore
!dev-python/twisted-mail
!dev-python/twisted-names
- !dev-python/twisted-words
+ !dev-python/twisted-news
+ !dev-python/twisted-pair
+ !dev-python/twisted-runner
!dev-python/twisted-web
+ !dev-python/twisted-words
+"
+DEPEND="
test? (
dev-python/gmpy[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
diff --git a/dev-python/twisted/twisted-16.4.1.ebuild b/dev-python/twisted/twisted-16.4.1.ebuild
index ff816b602dd..37640ea8578 100644
--- a/dev-python/twisted/twisted-16.4.1.ebuild
+++ b/dev-python/twisted/twisted-16.4.1.ebuild
@@ -38,14 +38,18 @@ RDEPEND=">=dev-python/zope-interface-4.0.2[${PYTHON_USEDEP}]
>=dev-python/priority-1.1.0[${PYTHON_USEDEP}]
<dev-python/priority-2.0[${PYTHON_USEDEP}]
)
-"
-DEPEND="
- !dev-python/twisted-core
!dev-python/twisted-conch
+ !dev-python/twisted-core
+ !dev-python/twisted-lore
!dev-python/twisted-mail
!dev-python/twisted-names
- !dev-python/twisted-words
+ !dev-python/twisted-news
+ !dev-python/twisted-pair
+ !dev-python/twisted-runner
!dev-python/twisted-web
+ !dev-python/twisted-words
+"
+DEPEND="
test? (
dev-python/gmpy[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]