summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/calligra/Manifest1
-rw-r--r--app-office/calligra/calligra-2.9.6.ebuild227
-rw-r--r--app-office/calligra/calligra-9999.ebuild77
-rw-r--r--app-office/calligra/files/calligra-2.9.6-ghns-linking.patch11
-rw-r--r--app-office/calligra/files/calligra-2.9.6-version.patch24
-rw-r--r--app-office/calligra/metadata.xml1
6 files changed, 299 insertions, 42 deletions
diff --git a/app-office/calligra/Manifest b/app-office/calligra/Manifest
index 1ac78609e00..39ae24ac8d2 100644
--- a/app-office/calligra/Manifest
+++ b/app-office/calligra/Manifest
@@ -1,2 +1,3 @@
DIST calligra-2.8.5.tar.xz 138928992 SHA256 92b8828ec64b46124b29a03bae13c143e3ed771adf3186fa938c765e5eac2fbd SHA512 09e32b7ce2415daae2ac3c1871fc1bc270210cbf5bc774f622922f8adb20e639db3dfb16c2974404b4395b30f8367a7ddd0016363a8b3e46fa24ff3fde1e4c14 WHIRLPOOL b4cc14353b7f9a457510a745b711283481f969e10ffee2847253b123ba2ea03f61d8abfdda2bcdb463c6bba8f2d8634e1536259f5be3d44778104bc8f28f79fe
DIST calligra-2.8.7.tar.xz 138966248 SHA256 af6b8b74ea077e5bbfa398e3ae96866b9a3ccfbc10224e9f341e59643be80eb5 SHA512 e09fcbb6708d73db3b31027c4393a138fbf5c47d1b777dd4a3b94f6e668d67ac963cfadb320350c63f1b2d1173edc67dc2100704899176c196865fb4d2ce7442 WHIRLPOOL ce082f04cfb7947219e317ba9a4a6ce436a3aa0784f1cad6206f3febd072f177961111ccbb89227d3c8dede1eafc647409b26f1f4fb304b1d482db0fe8c758b9
+DIST calligra-2.9.6.tar.xz 194239580 SHA256 78564137133e2f45065085df66ce2ab31478517c10163a06ba690a2d3a98a184 SHA512 d51b20c3d53a09ced3347b117de6827c5c29e31b198eff8bc136f0d6f604991371c6c4705d0ff3c6bcc64c017f0a14139d4b0529b02973909d80a25223e59f07 WHIRLPOOL 848884f830e0b8b2c6b8ed73d11222598295ca56ed4db826f4a9c3d3be42d5a65f5e50879a4fed68d6ae004962b799e23d6978a0943ff6b8900728b62dec43c0
diff --git a/app-office/calligra/calligra-2.9.6.ebuild b/app-office/calligra/calligra-2.9.6.ebuild
new file mode 100644
index 00000000000..4031e5beaaa
--- /dev/null
+++ b/app-office/calligra/calligra-2.9.6.ebuild
@@ -0,0 +1,227 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# note: files that need to be checked for dependencies etc:
+# CMakeLists.txt, kexi/CMakeLists.txt kexi/migration/CMakeLists.txt
+# krita/CMakeLists.txt
+
+EAPI=5
+
+CHECKREQS_DISK_BUILD="4G"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS_LIVE_OVERRIDE="true"
+OPENGL_REQUIRED="optional"
+inherit check-reqs kde4-base versionator
+
+DESCRIPTION="KDE Office Suite"
+HOMEPAGE="http://www.calligra.org/"
+
+case ${PV} in
+ 2.[456789].[789]?)
+ # beta or rc releases
+ SRC_URI="mirror://kde/unstable/${P}/${P}.tar.xz" ;;
+ 2.[456789].?)
+ # stable releases
+ SRC_URI="mirror://kde/stable/${P}/${P}.tar.xz" ;;
+ 2.[456789].9999)
+ # stable branch live ebuild
+ SRC_URI="" ;;
+ 9999)
+ # master branch live ebuild
+ SRC_URI="" ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="4"
+
+if [[ ${KDE_BUILD_TYPE} == release ]] ; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+IUSE="attica color-management +crypt +eigen +exif fftw +fontconfig freetds
++glew +glib +gsf gsl import-filter +jpeg jpeg2k +kdcraw kde +kdepim +lcms
+marble mysql +okular openexr +pdf postgres spacenav sybase test tiff +threads
++truetype vc xbase +xml"
+
+# Don't use Active, it's broken on desktops.
+CAL_FTS="author braindump flow gemini karbon kexi krita plan sheets stage words"
+for cal_ft in ${CAL_FTS}; do
+ IUSE+=" calligra_features_${cal_ft}"
+done
+unset cal_ft
+
+REQUIRED_USE="
+ calligra_features_author? ( calligra_features_words )
+ calligra_features_gemini? ( opengl )
+ calligra_features_krita? ( eigen exif lcms opengl )
+ calligra_features_plan? ( kdepim )
+ calligra_features_sheets? ( eigen )
+ vc? ( calligra_features_krita )
+ test? ( calligra_features_karbon )
+"
+
+RDEPEND="
+ $(add_kdeapps_dep knewstuff)
+ dev-lang/perl
+ dev-libs/boost
+ dev-qt/qtcore:4[exceptions]
+ media-libs/libpng:0
+ sys-libs/zlib
+ virtual/libiconv
+ attica? ( dev-libs/libattica )
+ color-management? ( media-libs/opencolorio )
+ crypt? ( app-crypt/qca:2[qt4(+)] )
+ eigen? ( dev-cpp/eigen:3 )
+ exif? ( media-gfx/exiv2:= )
+ fftw? ( sci-libs/fftw:3.0 )
+ fontconfig? ( media-libs/fontconfig )
+ freetds? ( dev-db/freetds )
+ glib? ( dev-libs/glib:2 )
+ gsf? ( gnome-extra/libgsf )
+ gsl? ( sci-libs/gsl )
+ import-filter? (
+ app-text/libetonyek
+ app-text/libodfgen
+ app-text/libwpd:*
+ app-text/libwpg:*
+ app-text/libwps
+ dev-libs/librevenge
+ media-libs/libvisio
+ )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:0 )
+ kdcraw? ( $(add_kdeapps_dep libkdcraw) )
+ kde? ( $(add_kdebase_dep kactivities) )
+ kdepim? ( $(add_kdebase_dep kdepimlibs) )
+ lcms? (
+ media-libs/lcms:2
+ x11-libs/libX11
+ )
+ marble? ( $(add_kdeapps_dep marble) )
+ mysql? ( virtual/mysql )
+ okular? ( $(add_kdeapps_dep okular) )
+ opengl? (
+ media-libs/glew
+ virtual/glu
+ )
+ openexr? ( media-libs/openexr )
+ pdf? (
+ app-text/poppler:=
+ media-gfx/pstoedit
+ )
+ postgres? (
+ dev-db/postgresql:*
+ dev-libs/libpqxx
+ )
+ spacenav? ( dev-libs/libspnav )
+ sybase? ( dev-db/freetds )
+ tiff? ( media-libs/tiff:0 )
+ truetype? ( media-libs/freetype:2 )
+ vc? ( dev-libs/vc )
+ xbase? ( dev-db/xbase )
+ calligra_features_kexi? (
+ >=dev-db/sqlite-3.8.7:3[extensions(+)]
+ dev-libs/icu:=
+ )
+ calligra_features_krita? (
+ dev-qt/qtdeclarative:4
+ x11-libs/libX11
+ x11-libs/libXi
+ )
+ calligra_features_words? ( dev-libs/libxslt )
+"
+DEPEND="${RDEPEND}
+ x11-misc/shared-mime-info
+"
+
+[[ ${PV} == 9999 ]] && LANGVERSION="2.9" || LANGVERSION="$(get_version_component_range 1-2)"
+PDEPEND=">=app-office/calligra-l10n-${LANGVERSION}"
+
+# bug 394273
+RESTRICT=test
+
+PATCHES=(
+ "${FILESDIR}/${P}-version.patch"
+ "${FILESDIR}/${P}-ghns-linking.patch"
+)
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ kde4-base_pkg_setup
+ check-reqs_pkg_setup
+}
+
+src_configure() {
+ local cal_ft myproducts
+
+ # applications
+ for cal_ft in ${CAL_FTS}; do
+ use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ done
+
+ local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
+
+ # first write out things we want to hard-enable
+ mycmakeargs+=(
+ "-DGHNS=ON"
+ "-DWITH_Iconv=ON" # available on all supported arches and many more
+ )
+
+ # default disablers
+ mycmakeargs+=(
+ "-DCREATIVEONLY=OFF"
+ "-DPACKAGERS_BUILD=OFF"
+ "-DWITH_Soprano=OFF"
+ )
+
+ # regular options
+ mycmakeargs+=(
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with color-management OCIO)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with eigen Eigen3)
+ $(cmake-utils_use_with exif Exiv2)
+ $(cmake-utils_use_with fftw FFTW3)
+ $(cmake-utils_use_with fontconfig Fontconfig)
+ $(cmake-utils_use_with freetds FreeTDS)
+ $(cmake-utils_use_with glib GLIB2)
+ $(cmake-utils_use_with gsl GSL)
+ $(cmake-utils_use_with import-filter LibEtonyek)
+ $(cmake-utils_use_with import-filter LibOdfGen)
+ $(cmake-utils_use_with import-filter LibRevenge)
+ $(cmake-utils_use_with import-filter LibVisio)
+ $(cmake-utils_use_with import-filter LibWpd)
+ $(cmake-utils_use_with import-filter LibWpg)
+ $(cmake-utils_use_with import-filter LibWps)
+ $(cmake-utils_use_with jpeg JPEG)
+ $(cmake-utils_use_with jpeg2k OpenJPEG)
+ $(cmake-utils_use_with kdcraw Kdcraw)
+ $(cmake-utils_use_with kde KActivities)
+ $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with lcms LCMS2)
+ $(cmake-utils_use_with marble CalligraMarble)
+ $(cmake-utils_use_with mysql MySQL)
+ $(cmake-utils_use_with okular Okular)
+ $(cmake-utils_use_with openexr OpenEXR)
+ $(cmake-utils_use opengl USEOPENGL)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with pdf Pstoedit)
+ $(cmake-utils_use_with postgres CalligraPostgreSQL)
+ $(cmake-utils_use_build postgres pqxx)
+ $(cmake-utils_use_with spacenav Spnav)
+ $(cmake-utils_use_with sybase FreeTDS)
+ $(cmake-utils_use_with tiff TIFF)
+ $(cmake-utils_use_with threads Threads)
+ $(cmake-utils_use_with truetype Freetype)
+ $(cmake-utils_use_with vc Vc)
+ $(cmake-utils_use_with xbase XBase)
+ )
+
+ mycmakeargs+=( $(cmake-utils_use_build test cstester) )
+
+ kde4-base_src_configure
+}
diff --git a/app-office/calligra/calligra-9999.ebuild b/app-office/calligra/calligra-9999.ebuild
index bce7b6d2a7f..97cea479c13 100644
--- a/app-office/calligra/calligra-9999.ebuild
+++ b/app-office/calligra/calligra-9999.ebuild
@@ -11,7 +11,6 @@ EAPI=5
CHECKREQS_DISK_BUILD="4G"
KDE_HANDBOOK="optional"
KDE_LINGUAS_LIVE_OVERRIDE="true"
-KDE_MINIMAL="4.13.1"
OPENGL_REQUIRED="optional"
inherit check-reqs kde4-base versionator
@@ -40,13 +39,13 @@ if [[ ${KDE_BUILD_TYPE} == release ]] ; then
KEYWORDS="~amd64 ~arm ~x86"
fi
-IUSE="attica +crypt +eigen +exif fftw +fontconfig freetds +glib +gsf gsl
-import-filter +jpeg jpeg2k +kdcraw kde +kdepim +lcms marble mysql +okular
-openexr +pdf postgres spacenav sybase test tiff +threads +truetype vc xbase
-+xml"
+IUSE="attica color-management +crypt +eigen +exif fftw +fontconfig freetds
++glew +glib +gsf gsl import-filter +jpeg jpeg2k +kdcraw kde +kdepim +lcms
+marble mysql +okular openexr +pdf postgres spacenav sybase test tiff +threads
++truetype vc xbase +xml"
-# please do not sort here, order is same as in CMakeLists.txt
-CAL_FTS="words stage sheets author karbon krita kexi flow plan braindump"
+# Don't use Active, it's broken on desktops.
+CAL_FTS="author braindump flow gemini karbon kexi krita plan sheets stage words"
for cal_ft in ${CAL_FTS}; do
IUSE+=" calligra_features_${cal_ft}"
done
@@ -54,7 +53,8 @@ unset cal_ft
REQUIRED_USE="
calligra_features_author? ( calligra_features_words )
- calligra_features_krita? ( eigen exif lcms )
+ calligra_features_gemini? ( opengl )
+ calligra_features_krita? ( eigen exif lcms opengl )
calligra_features_plan? ( kdepim )
calligra_features_sheets? ( eigen )
vc? ( calligra_features_krita )
@@ -62,28 +62,17 @@ REQUIRED_USE="
"
RDEPEND="
- !app-office/karbon
- !app-office/kexi
- !app-office/koffice-data
- !app-office/koffice-l10n
- !app-office/koffice-libs
- !app-office/koffice-meta
- !app-office/kplato
- !app-office/kpresenter
- !app-office/krita
- !app-office/kspread
- !app-office/kword
$(add_kdeapps_dep knewstuff)
dev-lang/perl
dev-libs/boost
dev-qt/qtcore:4[exceptions]
media-libs/libpng:0
sys-libs/zlib
- >=dev-qt/qtgui-4.8.1-r1:4
virtual/libiconv
attica? ( dev-libs/libattica )
+ color-management? ( media-libs/opencolorio )
crypt? ( app-crypt/qca:2[qt4(+)] )
- eigen? ( dev-cpp/eigen:2 )
+ eigen? ( dev-cpp/eigen:3 )
exif? ( media-gfx/exiv2:= )
fftw? ( sci-libs/fftw:3.0 )
fontconfig? ( media-libs/fontconfig )
@@ -97,6 +86,7 @@ RDEPEND="
app-text/libwpd:*
app-text/libwpg:*
app-text/libwps
+ dev-libs/librevenge
media-libs/libvisio
)
jpeg? ( virtual/jpeg:0 )
@@ -124,14 +114,14 @@ RDEPEND="
dev-db/postgresql:*
dev-libs/libpqxx
)
- spacenav? ( dev-libs/libspnav )
+ spacenav? ( dev-libs/libspnav )
sybase? ( dev-db/freetds )
tiff? ( media-libs/tiff:0 )
truetype? ( media-libs/freetype:2 )
vc? ( dev-libs/vc )
xbase? ( dev-db/xbase )
calligra_features_kexi? (
- >=dev-db/sqlite-3.7.9:3[extensions(+)]
+ >=dev-db/sqlite-3.8.7:3[extensions(+)]
dev-libs/icu:=
)
calligra_features_krita? (
@@ -141,13 +131,17 @@ RDEPEND="
)
calligra_features_words? ( dev-libs/libxslt )
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ x11-misc/shared-mime-info
+"
-[[ ${PV} == 9999 ]] && LANGVERSION="2.4" || LANGVERSION="$(get_version_component_range 1-2)"
+[[ ${PV} == 9999 ]] && LANGVERSION="2.9" || LANGVERSION="$(get_version_component_range 1-2)"
PDEPEND=">=app-office/calligra-l10n-${LANGVERSION}"
-RESTRICT=test
# bug 394273
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}/${PN}-2.9.6-ghns-linking.patch" )
pkg_pretend() {
check-reqs_pkg_pretend
@@ -159,19 +153,23 @@ pkg_setup() {
}
src_configure() {
- local cal_ft
+ local cal_ft myproducts
+
+ # applications
+ for cal_ft in ${CAL_FTS}; do
+ use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ done
+
+ local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
# first write out things we want to hard-enable
- local mycmakeargs=(
- "-DWITH_PNG=ON"
- "-DWITH_ZLIB=ON"
+ mycmakeargs+=(
"-DGHNS=ON"
"-DWITH_Iconv=ON" # available on all supported arches and many more
)
# default disablers
mycmakeargs+=(
- "-DBUILD_active=OFF" # we dont support active gui, maybe arm could
"-DCREATIVEONLY=OFF"
"-DPACKAGERS_BUILD=OFF"
"-DWITH_Soprano=OFF"
@@ -180,8 +178,9 @@ src_configure() {
# regular options
mycmakeargs+=(
$(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with color-management OCIO)
$(cmake-utils_use_with crypt QCA2)
- $(cmake-utils_use_with eigen Eigen2)
+ $(cmake-utils_use_with eigen Eigen3)
$(cmake-utils_use_with exif Exiv2)
$(cmake-utils_use_with fftw FFTW3)
$(cmake-utils_use_with fontconfig Fontconfig)
@@ -190,6 +189,7 @@ src_configure() {
$(cmake-utils_use_with gsl GSL)
$(cmake-utils_use_with import-filter LibEtonyek)
$(cmake-utils_use_with import-filter LibOdfGen)
+ $(cmake-utils_use_with import-filter LibRevenge)
$(cmake-utils_use_with import-filter LibVisio)
$(cmake-utils_use_with import-filter LibWpd)
$(cmake-utils_use_with import-filter LibWpg)
@@ -200,15 +200,14 @@ src_configure() {
$(cmake-utils_use_with kde KActivities)
$(cmake-utils_use_with kdepim KdepimLibs)
$(cmake-utils_use_with lcms LCMS2)
- $(cmake-utils_use_with marble Marble)
+ $(cmake-utils_use_with marble CalligraMarble)
$(cmake-utils_use_with mysql MySQL)
$(cmake-utils_use_with okular Okular)
$(cmake-utils_use_with openexr OpenEXR)
- $(cmake-utils_use_with opengl GLEW)
- $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use opengl USEOPENGL)
$(cmake-utils_use_with pdf Poppler)
$(cmake-utils_use_with pdf Pstoedit)
- $(cmake-utils_use_with postgres PostgreSQL)
+ $(cmake-utils_use_with postgres CalligraPostgreSQL)
$(cmake-utils_use_build postgres pqxx)
$(cmake-utils_use_with spacenav Spnav)
$(cmake-utils_use_with sybase FreeTDS)
@@ -219,13 +218,7 @@ src_configure() {
$(cmake-utils_use_with xbase XBase)
)
- # applications
- for cal_ft in ${CAL_FTS}; do
- mycmakeargs+=( $(cmake-utils_use_build calligra_features_${cal_ft} ${cal_ft}) )
- done
mycmakeargs+=( $(cmake-utils_use_build test cstester) )
- # filters
-
kde4-base_src_configure
}
diff --git a/app-office/calligra/files/calligra-2.9.6-ghns-linking.patch b/app-office/calligra/files/calligra-2.9.6-ghns-linking.patch
new file mode 100644
index 00000000000..b150972b146
--- /dev/null
+++ b/app-office/calligra/files/calligra-2.9.6-ghns-linking.patch
@@ -0,0 +1,11 @@
+--- calligra-2.9.6/libs/widgets/CMakeLists.txt.orig 2015-08-09 21:35:06.673116594 +0200
++++ calligra-2.9.6/libs/widgets/CMakeLists.txt 2015-08-09 21:47:31.458881310 +0200
+@@ -102,7 +102,7 @@
+ target_link_libraries(kowidgets kotext pigmentcms kowidgetutils ${KDE4_KIO_LIBS})
+
+ if(GHNS)
+- target_link_libraries(kowidgets {KDE4_KNEWSTUFF3_LIBS})
++ target_link_libraries(kowidgets ${KDE4_KNEWSTUFF3_LIBS})
+ endif ()
+
+ target_link_libraries(kowidgets LINK_INTERFACE_LIBRARIES kotext pigmentcms kowidgetutils ${KDE4_KDEUI_LIBS})
diff --git a/app-office/calligra/files/calligra-2.9.6-version.patch b/app-office/calligra/files/calligra-2.9.6-version.patch
new file mode 100644
index 00000000000..277d65ff71d
--- /dev/null
+++ b/app-office/calligra/files/calligra-2.9.6-version.patch
@@ -0,0 +1,24 @@
+From: Boudewijn Rempt <boud@valdyas.org>
+Date: Thu, 09 Jul 2015 06:14:05 +0000
+Subject: Update to 2.9.6
+X-Git-Url: http://quickgit.kde.org/?p=calligra.git&a=commitdiff&h=8d47cbdc81bbc3853837c6fc342d5b2dc77c3c0a
+---
+Update to 2.9.6
+---
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,10 +27,10 @@
+
+ # define common versions of Calligra applications, used to generate calligraversion.h
+ # update these version for every release:
+-set(CALLIGRA_VERSION_STRING "2.9.5")
++set(CALLIGRA_VERSION_STRING "2.9.6")
+ set(CALLIGRA_VERSION_MAJOR 2)
+ set(CALLIGRA_STABLE_VERSION_MINOR 9)
+-set(CALLIGRA_VERSION_RELEASE 5) # 89 for Alpha, increase for next test releases, set 0 for first Stable, etc.
++set(CALLIGRA_VERSION_RELEASE 6) # 89 for Alpha, increase for next test releases, set 0 for first Stable, etc.
+ #set(CALLIGRA_ALPHA 1) # uncomment only for Pre-Alpha and Alpha
+ #set(CALLIGRA_BETA 1) # uncomment only for Beta
+ #set(CALLIGRA_RC 1) # uncomment only for RC
diff --git a/app-office/calligra/metadata.xml b/app-office/calligra/metadata.xml
index e0edfb23c06..e2a729d6121 100644
--- a/app-office/calligra/metadata.xml
+++ b/app-office/calligra/metadata.xml
@@ -5,6 +5,7 @@
<herd>openoffice</herd>
<use>
<flag name="attica">Get hot stuff with <pkg>dev-libs/libattica</pkg></flag>
+ <flag name="color-management">Enable color management via <pkg>media-libs/opencolorio</pkg></flag>
<flag name="eigen">Enable <pkg>dev-cpp/eigen</pkg> mathematical templates support</flag>
<flag name="glew">Enable <pkg>media-libs/glew</pkg> opengl extension library support</flag>
<flag name="glib">Enable support for C library routines from <pkg>dev-libs/glib</pkg></flag>