summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/beaker/beaker-1.8.1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/beaker/beaker-1.8.1.ebuild b/dev-python/beaker/beaker-1.8.1.ebuild
index 76ad4a3b3b7..c44df31f8d9 100644
--- a/dev-python/beaker/beaker-1.8.1.ebuild
+++ b/dev-python/beaker/beaker-1.8.1.ebuild
@@ -24,11 +24,20 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
$(python_gen_impl_dep sqlite)
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pycrypto[${PYTHON_USEDEP}]
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
dev-python/sqlalchemy[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}]
)"
+python_prepare_all() {
+ # disarm pycrypto dep to allow || ( pycryptodome pycrypto )
+ sed -i -e "/TEST/s:'pycrypto'::" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
esetup.py test
}