summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/openastromenace/openastromenace-1.3.2-r1.ebuild2
-rw-r--r--games-action/openastromenace/openastromenace-1.3.2.ebuild5
2 files changed, 4 insertions, 3 deletions
diff --git a/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild b/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
index ef7a4f821d8..cdd657e1958 100644
--- a/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
+++ b/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
@@ -28,7 +28,7 @@ RDEPEND=${DEPEND}
S=${WORKDIR}/AstroMenace
src_prepare() {
- default
+ cmake-utils_src_prepare
# no messing with CXXFLAGS please.
sed -i -e '/-Os/d' CMakeLists.txt || die
diff --git a/games-action/openastromenace/openastromenace-1.3.2.ebuild b/games-action/openastromenace/openastromenace-1.3.2.ebuild
index a84ba605738..02e004964e5 100644
--- a/games-action/openastromenace/openastromenace-1.3.2.ebuild
+++ b/games-action/openastromenace/openastromenace-1.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -27,9 +27,10 @@ RDEPEND=${DEPEND}
S=${WORKDIR}/AstroMenace
src_prepare() {
+ cmake-utils_src_prepare
+
# no messing with CXXFLAGS please.
sed -i -e '/-Os/d' CMakeLists.txt || die
- epatch_user # bug #542930
}
src_configure() {