summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/ee/ee-1.5.2.ebuild1
-rw-r--r--app-editors/ee/files/ee-signal.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/app-editors/ee/ee-1.5.2.ebuild b/app-editors/ee/ee-1.5.2.ebuild
index 0d343a67d9e..fc1aec479af 100644
--- a/app-editors/ee/ee-1.5.2.ebuild
+++ b/app-editors/ee/ee-1.5.2.ebuild
@@ -20,6 +20,7 @@ S="${WORKDIR}/easyedit-${PV}"
PATCHES=(
"${FILESDIR}"/${PN}-init-location.patch
+ "${FILESDIR}"/${PN}-signal.patch
"${FILESDIR}"/${PN}-Wformat-security.patch
)
DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
diff --git a/app-editors/ee/files/ee-signal.patch b/app-editors/ee/files/ee-signal.patch
new file mode 100644
index 00000000000..41cfa401306
--- /dev/null
+++ b/app-editors/ee/files/ee-signal.patch
@@ -0,0 +1,11 @@
+--- a/ee.c
++++ b/ee.c
+@@ -552,7 +552,7 @@
+ {
+ int counter;
+
+- for (counter = 1; counter < SIGUNUSED; counter++)
++ for (counter = 1; counter < SIGSYS; counter++)
+ signal(counter, SIG_IGN);
+
+ signal(SIGCHLD, SIG_DFL);