summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/icdiff/Manifest1
-rw-r--r--app-misc/icdiff/files/icdiff-1.7.3-dont-check-changelog.patch16
-rw-r--r--app-misc/icdiff/icdiff-1.7.3.ebuild28
-rw-r--r--app-misc/icdiff/metadata.xml15
4 files changed, 60 insertions, 0 deletions
diff --git a/app-misc/icdiff/Manifest b/app-misc/icdiff/Manifest
new file mode 100644
index 00000000000..8063740b43e
--- /dev/null
+++ b/app-misc/icdiff/Manifest
@@ -0,0 +1 @@
+DIST icdiff-1.7.3.tar.gz 20215 SHA256 5161265f72a7c9c1d2d7b0780a381743ef3d3127944a96786422802a6bc14ca5 SHA512 ae8ca394c3fdf820d4795282672bc44eb01f88f9614d6240f035c31f99130b188185a0e241c3c17974d76f604b85ef48aa8296835b5dfb46463a88cb1f68d305 WHIRLPOOL 994bbc53673db6559444908b9a08e71283060648fdbc86e607b5ee229a933d13627b4e02b7b41fc25bf41021b9d86bed4d9e1b9df978922102b724e7be0a4642
diff --git a/app-misc/icdiff/files/icdiff-1.7.3-dont-check-changelog.patch b/app-misc/icdiff/files/icdiff-1.7.3-dont-check-changelog.patch
new file mode 100644
index 00000000000..1a9f0c957cd
--- /dev/null
+++ b/app-misc/icdiff/files/icdiff-1.7.3-dont-check-changelog.patch
@@ -0,0 +1,16 @@
+diff --git a/test.sh b/test.sh
+index 264c696..1bb7290 100755
+--- a/test.sh
++++ b/test.sh
+@@ -97,11 +97,6 @@ check_gold gold-67-wf.txt tests/input-{6,7}.txt --cols=80 --whole-file
+ check_gold gold-67-ln.txt tests/input-{6,7}.txt --cols=80 --line-numbers
+ check_gold gold-67-u3.txt tests/input-{6,7}.txt --cols=80 -U 3
+
+-if [ $(./icdiff --version | awk '{print $NF}') != $(head -n 1 ChangeLog) ]; then
+- echo "Version mismatch between ChangeLog and icdiff source."
+- fail
+-fi
+-
+ if ! $REGOLD; then
+ echo PASS
+ fi
diff --git a/app-misc/icdiff/icdiff-1.7.3.ebuild b/app-misc/icdiff/icdiff-1.7.3.ebuild
new file mode 100644
index 00000000000..5c53d1f78c3
--- /dev/null
+++ b/app-misc/icdiff/icdiff-1.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=(python2_7 python3_4 python3_5)
+
+inherit distutils-r1
+
+DESCRIPTION="Colourized diff that supports side-by-side diffing"
+HOMEPAGE="http://www.jefftk.com/icdiff"
+SRC_URI="https://github.com/jeffkaufman/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.3-dont-check-changelog.patch"
+)
+
+DOCS=(README.md ChangeLog)
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+python_test() {
+ ./test.sh "${EPYTHON%.*}" || die "Tests failed"
+}
diff --git a/app-misc/icdiff/metadata.xml b/app-misc/icdiff/metadata.xml
new file mode 100644
index 00000000000..81d6a4b6db7
--- /dev/null
+++ b/app-misc/icdiff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jeffkaufman/icdiff</remote-id>
+ </upstream>
+</pkgmetadata>