summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/udk/udk-2015.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-boot/udk/udk-2015.ebuild b/sys-boot/udk/udk-2015.ebuild
index 8061f63ed8c..0d0ea384e54 100644
--- a/sys-boot/udk/udk-2015.ebuild
+++ b/sys-boot/udk/udk-2015.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,21 +8,23 @@ PYTHON_REQ_USE="sqlite"
inherit flag-o-matic multiprocessing python-single-r1 toolchain-funcs versionator
+MY_V="${PN^^}$(get_version_component_range 1)"
+
DESCRIPTION="Tianocore UEFI Development kit"
HOMEPAGE="http://www.tianocore.org/edk2/"
-MY_V="${PN^^}$(get_version_component_range 1)"
SRC_URI="https://github.com/tianocore/${PN}/releases/download/${MY_V}/${MY_V}.Complete.MyWorkSpace.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
-
-DEPEND="app-arch/unzip
- dev-lang/nasm
- ${PYTHON_DEPS}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-lang/nasm"
+
S="${WORKDIR}/MyWorkSpace"
pkg_setup() {