summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/onanomsg/Manifest1
-rw-r--r--dev-ml/onanomsg/metadata.xml11
-rw-r--r--dev-ml/onanomsg/onanomsg-1.0.ebuild47
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/onanomsg/Manifest b/dev-ml/onanomsg/Manifest
new file mode 100644
index 00000000000..1d426dc0c21
--- /dev/null
+++ b/dev-ml/onanomsg/Manifest
@@ -0,0 +1 @@
+DIST onanomsg-1.0.tar.gz 13519 SHA256 d133f8998f8c2c655ce01664b3f64b741192af76ec7ac9486b2fa0be51f51f8b SHA512 d940f842f795c9d681755795f83694aceab23eb87c7cb66f2b8f643147ca58f30b43049e8c035e3f08392d9c2f611a75254d4ba999b337cc84d7b52f8f36218f WHIRLPOOL 9f5b992cc7c1fc4d92b5aec0db2a8cfebb69da34accd13dc0193adbbeebfd4ca5f163ac61b6ccbb44f440a998fd4a0d6ede35b16fe82d5c0305f16f4728a8747
diff --git a/dev-ml/onanomsg/metadata.xml b/dev-ml/onanomsg/metadata.xml
new file mode 100644
index 00000000000..80c7e9f7a50
--- /dev/null
+++ b/dev-ml/onanomsg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+ <use>
+ <flag name="lwt">Enables lwt support.</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/onanomsg/onanomsg-1.0.ebuild b/dev-ml/onanomsg/onanomsg-1.0.ebuild
new file mode 100644
index 00000000000..fe9038e90de
--- /dev/null
+++ b/dev-ml/onanomsg/onanomsg-1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="nanomsg bindings for OCaml"
+HOMEPAGE="https://github.com/rgrinberg/onanomsg"
+SRC_URI="https://github.com/rgrinberg/onanomsg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+lwt +ocamlopt test"
+
+RDEPEND="
+ dev-libs/nanomsg:=
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/ocaml-ctypes:=
+ dev-ml/ocaml-ipaddr:=[ocamlopt?]
+ dev-ml/ppx_deriving:=[ocamlopt?]
+ dev-ml/ocaml-containers:=[ocamlopt?]
+ lwt? ( dev-ml/lwt:=[ocamlopt?] )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ lwt=$(usex lwt true false) \
+ ounit=$(usex test true false) \
+ || die
+}
+
+src_install() {
+ opam-installer \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ || die
+ dodoc CHANGES README.md
+}