summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/kakoune/files/kakoune-makefile.patch6
-rw-r--r--app-editors/kakoune/kakoune-0_pre20160515-r1.ebuild (renamed from app-editors/kakoune/kakoune-0_pre20160515.ebuild)14
-rw-r--r--app-editors/kakoune/kakoune-9999.ebuild14
3 files changed, 12 insertions, 22 deletions
diff --git a/app-editors/kakoune/files/kakoune-makefile.patch b/app-editors/kakoune/files/kakoune-makefile.patch
index 076c42f92ea..54a22d5ac92 100644
--- a/app-editors/kakoune/files/kakoune-makefile.patch
+++ b/app-editors/kakoune/files/kakoune-makefile.patch
@@ -24,9 +24,11 @@ index c79c270..9409a8c 100644
sharedir := $(DESTDIR)$(PREFIX)/share/kak
docdir := $(DESTDIR)$(PREFIX)/share/doc/kak
@@ -53,11 +51,10 @@ else ifneq (,$(findstring CYGWIN,$(os)))
- LIBS += -lncursesw -lboost_regex -ldbghelp
+- LIBS += -lncursesw -lboost_regex -ldbghelp
++ LIBS += -lboost_regex -ldbghelp
else
- LIBS += -lncursesw -lboost_regex
+- LIBS += -lncursesw -lboost_regex
++ LIBS += -lboost_regex
- CPPFLAGS += -I$(NCURSESW_INCLUDE)
LDFLAGS += -rdynamic
endif
diff --git a/app-editors/kakoune/kakoune-0_pre20160515.ebuild b/app-editors/kakoune/kakoune-0_pre20160515-r1.ebuild
index 524324d6dd5..42293c86054 100644
--- a/app-editors/kakoune/kakoune-0_pre20160515.ebuild
+++ b/app-editors/kakoune/kakoune-0_pre20160515-r1.ebuild
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug"
RDEPEND="
- sys-libs/ncurses:*[unicode]
+ sys-libs/ncurses:=[unicode]
dev-libs/boost
"
DEPEND="
@@ -31,18 +31,12 @@ PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
src_configure() {
append-cppflags $(pkg-config --cflags ncursesw)
+ append-libs $(pkg-config --libs ncursesw)
export CXX=$(tc-getCXX)
export debug=$(usex debug)
-}
-
-src_compile() {
- emake -C src
-}
-
-src_test() {
- emake -C src test
+ S="${WORKDIR}/${P}/src"
}
src_install() {
- emake -C src DESTDIR="${D}" PREFIX="/usr" install
+ emake DESTDIR="${D}" PREFIX="/usr" install
}
diff --git a/app-editors/kakoune/kakoune-9999.ebuild b/app-editors/kakoune/kakoune-9999.ebuild
index f448c1b5403..96ba4987975 100644
--- a/app-editors/kakoune/kakoune-9999.ebuild
+++ b/app-editors/kakoune/kakoune-9999.ebuild
@@ -16,7 +16,7 @@ KEYWORDS=""
IUSE="debug"
RDEPEND="
- sys-libs/ncurses:*[unicode]
+ sys-libs/ncurses:=[unicode]
dev-libs/boost
"
DEPEND="
@@ -29,18 +29,12 @@ PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
src_configure() {
append-cppflags $(pkg-config --cflags ncursesw)
+ append-libs $(pkg-config --libs ncursesw)
export CXX=$(tc-getCXX)
export debug=$(usex debug)
-}
-
-src_compile() {
- emake -C src
-}
-
-src_test() {
- emake -C src test
+ S="${WORKDIR}/${P}/src"
}
src_install() {
- emake -C src DESTDIR="${D}" PREFIX="/usr" install
+ emake DESTDIR="${D}" PREFIX="/usr" install
}