summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/bti/Manifest1
-rw-r--r--net-misc/bti/bti-031-r1.ebuild42
-rw-r--r--net-misc/bti/files/bti-031-nonGNU.patch32
3 files changed, 0 insertions, 75 deletions
diff --git a/net-misc/bti/Manifest b/net-misc/bti/Manifest
index 8a987f20be1..43347fa82d7 100644
--- a/net-misc/bti/Manifest
+++ b/net-misc/bti/Manifest
@@ -1,2 +1 @@
-DIST bti-031.tar.bz2 89027 SHA256 1b2f509a818ec6b1a036daff9d56a9c7b2640741df3d0ec89376775890187cd5 SHA512 d930013eb45bdfbaa914444460f74448c8bb62f255b2db5c771736ba7c5bb71d0cf4651db76eba0f05fbd6c6a175c7bc8942d7657588bd27e18bf409bf02d9fd WHIRLPOOL 43cf7b10e01cc0f0c076faec79f9ce2f18fdd23350a72d1d081638f2d0c55f323e395fe088379455e6846b12df13a76fcbd4cc6f4bfc2835040e5c961734ed01
DIST bti-034.tar.xz 93328 SHA256 8b4a1a11f529f83956468acadaea9d11db4f03e82afe07fecb84b2d00e9eae83 SHA512 2b7cd66cff617f7592863a1a8e03754b3dea314c8eeb98bf0993601d4d4db848a74b26941bbd04f57a348bf0d02aefca4e3125f00fed531a67a3f17f36e665ba WHIRLPOOL d75f679aa4d1c766a88a9124073befa4c3b320304c747d756aba0169918cce7c44660b8627002d8fa3503a635bb0b10c68f032837b93504f378f7093dfc02768
diff --git a/net-misc/bti/bti-031-r1.ebuild b/net-misc/bti/bti-031-r1.ebuild
deleted file mode 100644
index 30f879d12fc..00000000000
--- a/net-misc/bti/bti-031-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit bash-completion-r1 eutils
-
-DESCRIPTION="A command line twitter/identi.ca client"
-HOMEPAGE="https://gregkh.github.com/bti/"
-SRC_URI="mirror://kernel/software/web/bti/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-
-RDEPEND="
- net-misc/curl
- dev-libs/libxml2
- dev-libs/libpcre
- net-libs/liboauth
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-# Readline is dynamically loaded, for whatever reason, and can use
-# libedit as an alternative...
-RDEPEND="${RDEPEND}
- || ( sys-libs/readline dev-libs/libedit )"
-
-DOCS=( bti.example README RELEASE-NOTES )
-
-src_prepare() {
- # Allow compilation on non-GNU systems, bug #384311
- epatch "${FILESDIR}/${PN}-031-nonGNU.patch"
-}
-
-src_install() {
- default
- dobashcomp bti-bashcompletion
-}
diff --git a/net-misc/bti/files/bti-031-nonGNU.patch b/net-misc/bti/files/bti-031-nonGNU.patch
deleted file mode 100644
index 14b10c1fb83..00000000000
--- a/net-misc/bti/files/bti-031-nonGNU.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Avoid using strchrnul, it's a GNU addition. The code in question,
-actually doesn't really benefit from strchrnul's behaviour.
-
---- config.c
-+++ config.c
-@@ -351,20 +351,21 @@
- * marker if it occurs at the beginning of the line, or after
- * whitespace
- */
-- hashmarker = strchrnul(line, '#');
-+ hashmarker = strchr(line, '#');
- if (line == hashmarker)
- line[0] = '\0';
- else {
-- while (hashmarker[0] != '\0') {
-+ while (hashmarker != NULL) {
- --hashmarker;
-- if (isblank(hashmarker[0]))
-+ if (isblank(hashmarker[0])) {
- hashmarker[0] = '\0';
-- else {
-+ break;
-+ } else {
- /*
- * false positive; '#' occured
- * within a string
- */
-- hashmarker = strchrnul(hashmarker+2, '#');
-+ hashmarker = strchr(hashmarker+2, '#');
- }
- }
- }