summaryrefslogtreecommitdiff
path: root/app-admin/chrootuid/chrootuid-1.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/chrootuid/chrootuid-1.3-r2.ebuild')
-rw-r--r--app-admin/chrootuid/chrootuid-1.3-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/chrootuid/chrootuid-1.3-r2.ebuild b/app-admin/chrootuid/chrootuid-1.3-r2.ebuild
new file mode 100644
index 00000000000..cdb02fef8c5
--- /dev/null
+++ b/app-admin/chrootuid/chrootuid-1.3-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${P/-/}"
+
+DESCRIPTION="Run a network service at low privilege level and restricted file system access"
+HOMEPAGE="ftp://ftp.porcupine.org/pub/security/index.html"
+SRC_URI="ftp://ftp.porcupine.org/pub/security/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dodoc README chrootuid_license
+ dobin chrootuid
+ doman chrootuid.1
+}