summaryrefslogtreecommitdiff
path: root/app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild')
-rw-r--r--app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild b/app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild
new file mode 100644
index 00000000000..f8c293aff03
--- /dev/null
+++ b/app-admin/pwcrypt/pwcrypt-1.2.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An improved version of cli-crypt (encrypts data sent to it from the cli)"
+HOMEPAGE="http://xjack.org/pwcrypt/"
+SRC_URI="http://xjack.org/pwcrypt/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DOCS=( CREDITS README )
+
+src_prepare() {
+ sed -i "s/make\( \|$\)/\$(MAKE)\1/g" Makefile.in || die
+ sed -i \
+ -e "/^LDFLAGS/s/= /= @LDFLAGS@ /" \
+ -e "/-install/s/ -s//" \
+ src/Makefile.in || die
+
+ tc-export CC
+}