summaryrefslogtreecommitdiff
path: root/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/systemrescuecd-x86/systemrescuecd-x86-4.7.1.ebuild')
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-4.7.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.7.1.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.7.1.ebuild
index d7cc39e4ee1..9ac4ee7db46 100644
--- a/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.7.1.ebuild
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-4.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -11,7 +11,9 @@ SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
LICENSE="GPL-2"
SLOT="${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
S=${WORKDIR}
@@ -20,6 +22,12 @@ RESTRICT="mirror"
src_install() {
insinto "/usr/share/${PN%-*}"
doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
}
pkg_postinst() {