summaryrefslogtreecommitdiff
path: root/app-arch/pdlzip/pdlzip-1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pdlzip/pdlzip-1.7.ebuild')
-rw-r--r--app-arch/pdlzip/pdlzip-1.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/pdlzip/pdlzip-1.7.ebuild b/app-arch/pdlzip/pdlzip-1.7.ebuild
new file mode 100644
index 00000000000..4c1b4e464d3
--- /dev/null
+++ b/app-arch/pdlzip/pdlzip-1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Public-domain version of lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/pdlzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/pdlzip/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}