summaryrefslogtreecommitdiff
path: root/app-arch/pdv/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pdv/files')
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-default-args.patch16
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-early-free.patch21
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-no-strip.patch13
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-opt.patch24
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-x-config.patch18
5 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/pdv/files/pdv-1.5.1-default-args.patch b/app-arch/pdv/files/pdv-1.5.1-default-args.patch
new file mode 100644
index 00000000000..dc61def911f
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-default-args.patch
@@ -0,0 +1,16 @@
+diff -ur pdv-1.5.1.orig/pdv.h pdv-1.5.1/pdv.h
+--- pdv-1.5.1.orig/pdv.h 2001-09-01 12:09:28.000000000 -0700
++++ pdv-1.5.1/pdv.h 2006-07-22 22:20:43.000000000 -0700
+@@ -47,9 +47,9 @@
+ char *cmd; /* command to execute after delivery */
+ char *hlpmsg; /* user help message */
+ char *agrmsg; /* optional agreement message */
+- char iscompressed; /* filter payload through uncompress */
+- char isatar; /* filter payload through tar */
+- char iszipped; /* use internal compression library */
++ signed char iscompressed; /* filter payload through uncompress */
++ signed char isatar; /* filter payload through tar */
++ signed char iszipped; /* use internal compression library */
+ off_t payloadstart; /* start of payload (after pdv stub) */
+ off_t metadatastart; /* start of payload data (at end of file) */
+ };
diff --git a/app-arch/pdv/files/pdv-1.5.1-early-free.patch b/app-arch/pdv/files/pdv-1.5.1-early-free.patch
new file mode 100644
index 00000000000..6896d9437f4
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-early-free.patch
@@ -0,0 +1,21 @@
+diff -ur pdv-1.5.1-orig/mkpkgutils.c pdv-1.5.1/mkpkgutils.c
+--- pdv-1.5.1-orig/mkpkgutils.c 2005-04-26 15:01:30.525131384 -0700
++++ pdv-1.5.1/mkpkgutils.c 2005-04-26 15:55:19.004327944 -0700
+@@ -114,8 +114,6 @@
+ if(access(fn_tst, R_OK) == 0)
+ fn = strdup(fn_tst);
+
+- free(fn_tst);
+-
+ /* if we could not find it then try the search path
+ including the current directory as a last resort */
+
+@@ -144,6 +142,8 @@
+ free(path);
+ } /* if(fn == NULL) */
+
++ free(fn_tst);
++
+ return fn;
+ } /* findpdv */
+
diff --git a/app-arch/pdv/files/pdv-1.5.1-no-strip.patch b/app-arch/pdv/files/pdv-1.5.1-no-strip.patch
new file mode 100644
index 00000000000..630bf5eb7c3
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-no-strip.patch
@@ -0,0 +1,13 @@
+diff -ur pdv-1.5.1-orig/pdv.c pdv-1.5.1/pdv.c
+--- pdv-1.5.1-orig/Makefile.in 2008-12-06 23:17:46.000000000 -0800
++++ pdv-1.5.1/Makefile.in 2008-12-06 23:18:37.000000000 -0800
+@@ -536,7 +536,8 @@
+ touch $@
+
+ pdv_fixed : pdv_fixed.c pdv
+- $(STRIPBIN) pdv
++ # let portage decide whether to strip binaries
++ #$(STRIPBIN) pdv
+ printf "%-5.5s" $$VERSION >> pdv
+ printf "\000\000\000\000\000\000\000\000" >> pdv
+ sleep 1
diff --git a/app-arch/pdv/files/pdv-1.5.1-opt.patch b/app-arch/pdv/files/pdv-1.5.1-opt.patch
new file mode 100644
index 00000000000..df3ebb1b669
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-opt.patch
@@ -0,0 +1,24 @@
+diff -ur pdv-1.5.1-orig/pdv.c pdv-1.5.1/pdv.c
+--- pdv-1.5.1-orig/pdv.c 2005-04-24 19:27:15.705946000 -0700
++++ pdv-1.5.1/pdv.c 2005-04-24 19:17:27.042436456 -0700
+@@ -79,7 +79,7 @@
+ int
+ main(int argc, char *argv[])
+ {
+- char opt;
++ int opt;
+ int retval = 0;
+ int showhelp = 0;
+ struct payload_st pld_data;
+diff -ur pdv-1.5.1-orig/pdvmkpkg.c pdv-1.5.1/pdvmkpkg.c
+--- pdv-1.5.1-orig/pdvmkpkg.c 2005-04-24 19:27:28.680973496 -0700
++++ pdv-1.5.1/pdvmkpkg.c 2005-04-24 19:21:49.992461976 -0700
+@@ -94,7 +94,7 @@
+ int promptusr = 0;
+ int nopts = 0;
+ int result;
+- char opt;
++ int opt;
+ struct stat payldstat;
+ struct payload_st pld_data;
+ struct pdvspec_st spec;
diff --git a/app-arch/pdv/files/pdv-1.5.1-x-config.patch b/app-arch/pdv/files/pdv-1.5.1-x-config.patch
new file mode 100644
index 00000000000..8bab9bee1bf
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-x-config.patch
@@ -0,0 +1,18 @@
+diff -ur pdv-1.5.1-orig/X11/configure.in pdv-1.5.1/X11/configure.in
+--- pdv-1.5.1-orig/X11/configure.in 2005-05-13 13:43:27.577544136 -0700
++++ pdv-1.5.1/X11/configure.in 2005-05-13 13:36:14.218424736 -0700
+@@ -17,8 +17,12 @@
+ AC_PATH_X
+
+ dnl Checks for libraries.
+-CFLAGS=-I$x_includes
+-LDFLAGS=-L$x_libraries
++if test "x$x_includes" != x ; then
++ CFLAGS="$CFLAGS -I$x_includes"
++fi
++if test "x$x_libraries" != x ; then
++ LDFLAGS="$LDFLAGS -L$x_libraries"
++fi
+
+ AC_CHECK_LIB(Xt, XtManageChild)
+ AC_CHECK_LIB(X11, XLoadFont)