summaryrefslogtreecommitdiff
path: root/app-arch/unrpa
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unrpa')
-rw-r--r--app-arch/unrpa/Manifest1
-rw-r--r--app-arch/unrpa/metadata.xml15
-rw-r--r--app-arch/unrpa/unrpa-1.4.1.ebuild30
-rw-r--r--app-arch/unrpa/unrpa-9999.ebuild30
4 files changed, 76 insertions, 0 deletions
diff --git a/app-arch/unrpa/Manifest b/app-arch/unrpa/Manifest
new file mode 100644
index 00000000000..394ba27649e
--- /dev/null
+++ b/app-arch/unrpa/Manifest
@@ -0,0 +1 @@
+DIST unrpa-1.4.1.tar.gz 14367 SHA256 a6f20fca0e00e09220933060c98180ad11d5a7633fc902684099b5f2c4806b0a SHA512 9b058adda9a39178950df4c39af40726cdca410f0fca699d0dec1bd5d7046c75c8811c8914c0c8756c29988b6362d3b4ad3756aa77f238eafb13d4414d3266cc WHIRLPOOL fc01837fa7a68e5121413c551abb1f9231adf04b677caec1017aaafb112da5546e5f68ea10b7cc68329bacb6499468c5b595196a4abe93ac9b7bcacb1aa5f89a
diff --git a/app-arch/unrpa/metadata.xml b/app-arch/unrpa/metadata.xml
new file mode 100644
index 00000000000..f35062a7ed7
--- /dev/null
+++ b/app-arch/unrpa/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <longdescription>
+ Unrpa is a script to extract files from archives created for
+ the Ren'Py Visual Novel Engine (http://www.renpy.org/)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Lattyware/unrpa</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/unrpa/unrpa-1.4.1.ebuild b/app-arch/unrpa/unrpa-1.4.1.ebuild
new file mode 100644
index 00000000000..ee99fdb00de
--- /dev/null
+++ b/app-arch/unrpa/unrpa-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
+else
+ SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Ren'Py's RPA data file extractor"
+HOMEPAGE="https://github.com/Lattyware/unrpa"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}
diff --git a/app-arch/unrpa/unrpa-9999.ebuild b/app-arch/unrpa/unrpa-9999.ebuild
new file mode 100644
index 00000000000..ee99fdb00de
--- /dev/null
+++ b/app-arch/unrpa/unrpa-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
+else
+ SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Ren'Py's RPA data file extractor"
+HOMEPAGE="https://github.com/Lattyware/unrpa"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}