summaryrefslogtreecommitdiff
path: root/app-backup
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/cachedir/Manifest1
-rw-r--r--app-backup/cachedir/cachedir-1.4.ebuild47
-rw-r--r--app-backup/cachedir/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/app-backup/cachedir/Manifest b/app-backup/cachedir/Manifest
new file mode 100644
index 00000000000..3129cb786fb
--- /dev/null
+++ b/app-backup/cachedir/Manifest
@@ -0,0 +1 @@
+DIST cachedir-1.4.tar.gz 16254 BLAKE2B f70fe693d614ab90c4b235c2979e9323eb41976ea8a97c4d3107af26f411553a86e0409b354483a6e3c9af956597c9a4114dc28829cc2ed55abe7c7dd3bb8a99 SHA512 dabeb36a4b99febafbfcc3bff4de625491eee6649cac6c03ef782415cfdd519d36911bed8ae6e7bb94b0afe6279b17fd99fcb87f0c2d2e37032a76fa516dd6c7
diff --git a/app-backup/cachedir/cachedir-1.4.ebuild b/app-backup/cachedir/cachedir-1.4.ebuild
new file mode 100644
index 00000000000..ca9b3bf689b
--- /dev/null
+++ b/app-backup/cachedir/cachedir-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tag/untag cache directories"
+HOMEPAGE="http://liw.fi/cachedir/"
+SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/cachedir/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+# test deps not supporting python 3
+RESTRICT="test"
+
+RDEPEND="dev-python/cliapp[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# dev-util/cmdtest[${PYTHON_USEDEP}]
+# )
+# "
+
+python_prepare_all() {
+ 2to3 -w setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+}
+
+src_test() {
+ addwrite /proc/self/comm
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py check
+}
diff --git a/app-backup/cachedir/metadata.xml b/app-backup/cachedir/metadata.xml
new file mode 100644
index 00000000000..b7595a302f2
--- /dev/null
+++ b/app-backup/cachedir/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+</pkgmetadata>